Autophone - Throbber stop regression 2016-03-09 in S1S2 on fx-team

RESOLVED FIXED in Firefox 48

Status

()

Firefox for Android
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bc, Assigned: jchen)

Tracking

(Blocks: 1 bug, {regression})

48 Branch
Firefox 49
regression
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 fixed, firefox49 fixed, fennec48+)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Autophone shows a regression from 2.5% to 6.9% in throbberstop on 2016-03-09

http://phonedash.mozilla.org/#/2016-03-09/2016-03-10/binning=repo-phonetype-phoneid-test_name-cached_label-metric&rejected=norejected&errorbars=errorbars&errorbartype=standarderror&valuetype=median&local-blank=on&throbberstop=on&second=on&fx-team=on&nexus-4-6=on&nexus-5-4=on&nexus-9-1=on

http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=b2b0a09c6e1af30437efc99c295d51598d86293d&tochange=82efa3bc873182d3ab5d450a1a784db7a3d1aba6

It appears in all tests and for first and second visits though local-blank has a clearer signal. It also appears later on mozilla-central and mozilla-inbound as the merges occur.

Looks like Bug 1252666 - Flip dom.push.enabled to true in Firefox for Android
(Reporter)

Updated

2 years ago
Summary: Autophone - 2016-03-09 Throbber stop regression in S1S2 on fx-team → Autophone - Throbber stop regression 2016-03-09 in S1S2 on fx-team

Comment 1

2 years ago
It looks like enabling push notifications regressed page load time.

Jim, can you look into this?

(Edwin, I wanted to make sure this is on the push team's radar.)
Flags: needinfo?(nchen)
Flags: needinfo?(edwong)
Assignee: nobody → nchen
tracking-fennec: ? → 48+
(Assignee)

Updated

2 years ago
Flags: needinfo?(nchen)
(Assignee)

Comment 2

2 years ago
Created attachment 8756954 [details] [diff] [review]
Delay initializing PushService and DLC (v1)

Delay initialization of PushService and DLC in GeckoApplication to after
the Gecko:Ready message. That way, hopefully they give up some CPU time
to other initialization tasks.
Attachment #8756954 - Flags: review?(snorp)
Attachment #8756954 - Flags: review?(snorp) → review+

Comment 4

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e97d36a133b7
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
(Assignee)

Comment 5

2 years ago
Comment on attachment 8756954 [details] [diff] [review]
Delay initializing PushService and DLC (v1)

Approval Request Comment
[Feature/regressing bug #]: Push
[User impact if declined]: Slower startup time due to push being enabled
[Describe test coverage new/current, TreeHerder]: Locally, m-c
[Risks and why]: There is one known regression (bug 1280446), which will be uplifted; otherwise the risk is small because the patch simply delays push initialization on startup
[String/UUID change made/needed]: None
Attachment #8756954 - Flags: approval-mozilla-beta?
status-firefox47: --- → unaffected
status-firefox48: --- → affected
Version: unspecified → 48 Branch
Comment on attachment 8756954 [details] [diff] [review]
Delay initializing PushService and DLC (v1)

Review of attachment 8756954 [details] [diff] [review]:
-----------------------------------------------------------------

This patch fixes slower startup time. Take it in 48 beta 7. The fix should be in fennec 48 beta 8.
Attachment #8756954 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 7

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/5c39f5f66157
status-firefox48: affected → fixed

Updated

2 years ago
Flags: needinfo?(edwong)
You need to log in before you can comment on or make changes to this bug.