[Widevine] On Netflix, if start movie from browse page black screen is displayed

RESOLVED DUPLICATE of bug 1269932

Status

()

RESOLVED DUPLICATE of bug 1269932
2 years ago
2 years ago

People

(Reporter: brindusat, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
[Affected versions]:
- User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 
- Build ID: 20160512030253

[Affected Platforms]:
- All Windows
- All Mac OS

[Prerequisites]:
- Widevine latest version is installed and enabled
- User-Agent Switcher add-on is installed (https://goo.gl/FKb70f) and it is set to fake Chrome User Agent.

[Steps to reproduce]:
1. Go to https://www.netflix.com/browse, scroll down and hover over a movie.
2. Click on Play button.


[Expected results]:
- The video should start to play.

[Actual results]:
- The video does NOT start, a black screen is displayed. In Browser console is displayed:
TypeError: window.cancelIdleCallback is not a function
 After refreshing(F5) the page, video is played without error.

[Notes]:
- This issue is not reproducible in Google Chrome.
- This issue is reproducible with most of the websites that use Widevine CDM.
> TypeError: window.cancelIdleCallback is not a function

I think this bug is a duplicate of bug 1269932 ("Netflix Widevine video playback fails when spoofing Chrome UA: TypeError: window.cancelIdleCallback is not a function"). cancelIdleCallback is a function that is implemented in Chrome but not Firefox. If Netflix chooses to use Widevine in Firefox, they will need to fix their player to not use the cancelIdleCallback function. Alternately, we can implement the function, which has already begun in bug 1198381.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269932
You need to log in before you can comment on or make changes to this bug.