Closed Bug 1272746 Opened 7 years ago Closed 6 years ago

Crash in mozilla::dom::ProtoAndIfaceCache::SizeOfIncludingThis

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1272160

People

(Reporter: milan, Unassigned)

References

Details

(Keywords: crash, Whiteboard: btpp-followup-2016-05-31)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-7b138156-a347-4843-833b-2f87e2160513.
=============================================================

Not a lot of crashes, but all of them are going to the memory reporter, and all of them are new to the 20160512030253 build, so it may be worth looking at it sooner.
khuey says this is probably the same as bug 1272160
Depends on: 1272160
On Mac these show up as [@ XPCWrappedNativeScope::AddSizeOfIncludingThis] due to inlining.
Crash Signature: [@ mozilla::dom::ProtoAndIfaceCache::SizeOfIncludingThis] → [@ mozilla::dom::ProtoAndIfaceCache::SizeOfIncludingThis] [@ XPCWrappedNativeScope::AddSizeOfIncludingThis]
(And Linux signature is the same as Mac.)
Looks like this hasn't been reported in a 49 build since bug 1272160 landed. That bug's patches have now been uplifted to 48 (currently Aurora) so if we don't see any reports there in a bit we can close this.
Whiteboard: btpp-followup-2016-05-31
I think we're good here.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1272160
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.