Evaluation in Browser Console/Web Console/Scratch Pad takes a long time. (decrypting with pbkdf2 algorithm).

RESOLVED DUPLICATE of bug 793345

Status

RESOLVED DUPLICATE of bug 793345
3 years ago
4 months ago

People

(Reporter: alice0775, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows 10
perf, regression

Firefox Tracking Flags

(firefox49- fix-optional)

Details

(Whiteboard: [parity-Chrome])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8752324 [details]
Bug1271947.txt

+++ This bug was initially created as a clone of Bug #1271947 +++

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36

Steps to reproduce:
1. Open Browser Console, Web Console or Scratch Pad
2. Paste JavaScript code in the attached file
3. Evaluate the code

Actual Results:
Nightly49 is 9 times slower than Chrome.
And Nightly49 is 2-3 times slower than Firefox38/31.

Browser   : Result
Chrome50  :  851  838  840
Firefox31 : 2740 2813 2783
Firefox38 : 3077 3045 3030
Firefox39 : 4668 4675 4668
Firefox40 : 4318 4334 4246
Firefox41 : 4525 4457 4468
Firefox42 : 5875 5808 5816
Firefox43 : 6249 6076 6124
Firefox44 : 7159 6949 7008
Firefox45 : 6969 6930 6896
Firefox46 : 6727 6613 6658
Firefox47 : 7217 7050 7164
Firefox48 : 7721 7716 7703
Firefox49 : 7900 7888 7884


Expected results:
No so




Actual results:

After Firefox updated from 44 to 45 version, we've got a problem that decryption process takes too long time (about 10 seconds) but under Firefox 44 and below it was about 1 second.


Expected results:

In Firefox 45 and above decryption process should take about 1 second.
(Reporter)

Comment 1

3 years ago
> Actual results:
> 
> After Firefox updated from 44 to 45 version, we've got a problem that decryption process takes
> too long time (about 10 seconds) but under Firefox 44 and below it was about 1 second.
> 
> 
> Expected results:
> 
> In Firefox 45 and above decryption process should take about 1 second.

Oops, paste error. 
Please ignore last 9 lines
(Reporter)

Updated

3 years ago
Whiteboard: [parity-Chrome]
Tracking this regression for 49 as it seems to be a fairly significant performance regression.

ni on bholley - Is this something you would look into or should it be passed on to someone else?
tracking-firefox49: --- → +
Flags: needinfo?(bobbyholley)
This looks like a dupe of Bug 793345.  I'm not sure what the columns in Comment 0 are representing exactly, but the perf appears to be bouncing around 44-47 if the first column is a measure of time.  The numbers do seem to get gradually worse over time, but even from the start it's 10x slower than the same code running in a script tag so fixing Bug 793345 looks like the most important piece here.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bobbyholley)
Resolution: --- → DUPLICATE
Duplicate of bug: 793345
This seems less of a sudden regression than something gradually getting worse since 38 or so. I don't think we need to track this.
tracking-firefox49: + → -
status-firefox49: affected → fix-optional

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.