Closed Bug 1272815 Opened 7 years ago Closed 7 years ago

Crash in IPCError-browser | (msgtype=0x580009,name=PDocAccessible::Msg_BindChildDoc) Processing error: message was deserialized,

Categories

(Core :: Disability Access APIs, defect)

x86
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1189277
Tracking Status
firefox49 --- affected

People

(Reporter: dbaron, Unassigned)

Details

(Keywords: crash, topcrash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-15da7fe9-28c6-4103-9fea-7fea82160512.
=============================================================

There have been a decent number of crashes with this signature since the IPCError-browser crash signature came into existence.
jimm, any ideas?
Flags: needinfo?(jmathies)
(In reply to Nicholas Nethercote [:njn] from comment #1)
> jimm, any ideas?

I strongly suspect the child process is failing to send a message before this one that tells the parent about a piece of the accessibility tree that this message wants us to use.  Then when we do get this one it seems bogus because it refers to objects we don't know about.  Unfortunately its really hard to know more than that without reproducing.  It might be fixing the missing message causing bug 1272706 fixes this too, but there might also be other problems.
Flags: needinfo?(jmathies)
dupe of a known a11y related crash in Nightly.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1189277
You need to log in before you can comment on or make changes to this bug.