Last child in inline relatively positioned element wrongly positioned when he's absolute

RESOLVED DUPLICATE of bug 489100

Status

()

--
major
RESOLVED DUPLICATE of bug 489100
3 years ago
2 years ago

People

(Reporter: cyril.auburtin, Unassigned)

Tracking

({css3})

49 Branch
Unspecified
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160513030539

Steps to reproduce:

https://jsfiddle.net/bzooopza/1/



Actual results:

the pseudo ::after element, or the last child <i> both appear at the end of the first line


Expected results:

they should appear at the end of the last line (behavior on webkit and edge)
(Reporter)

Updated

3 years ago
Severity: normal → major
Keywords: css3

Comment 1

3 years ago
Build ID 	20160518030234
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:49.0) Gecko/20100101 Firefox/49.0



Tested on Mac OS X 10.10 with FF Nightly 49.0a1 and I can reproduce it.
Status: UNCONFIRMED → NEW
Component: Untriaged → CSS Parsing and Computation
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489100
Component: CSS Parsing and Computation → Layout: R & A Pos
You need to log in before you can comment on or make changes to this bug.