inspector: replace textnode by whitespace creates empty element in markupview

RESOLVED DUPLICATE of bug 1304685

Status

()

Firefox
Developer Tools: Inspector
P2
normal
RESOLVED DUPLICATE of bug 1304685
a year ago
11 months ago

People

(Reporter: jdescottes, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8752611 [details]
empty-textnode-STR.gif

STRs:

- open data:text/html,<div>textnode<span>
- open inspector, inspect "textnode"
- in markupview, doubleclick to edit the text of "textnode"
- replace "textnode" by " "
- commit the change

ER: The empty textnode should be removed from the view
AR: An empty element remains instead of the textnode

Note, if you close and reopen the inspector, the empty textnode is gone.

Empty text nodes are normally filtered in the inspector actor ([1] & [2]), but it looks like this is not handled when updating nodes.
FILTER ON CLIMBING SHOES

Marking this one as a P2 because it makes the markup view look broken
Priority: -- → P2

Comment 2

11 months ago
I think we should close this as a duplicate of bug 1304685.
Please re-open if you think otherwise.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1304685
You need to log in before you can comment on or make changes to this bug.