Closed Bug 1273433 Opened 6 years ago Closed 6 years ago

<legend align=right> doesn't work

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: zcorpan, Assigned: MatsPalmgren_bugz)

References

Details

(Keywords: regression)

Attachments

(2 files)

See https://github.com/whatwg/html/pull/1252


<legend align=left/right> in vertical works in WebKit/Chromium but not in Gecko. (center works in Gecko.)

<!DOCTYPE html>
<style>html { writing-mode: vertical-lr } </style>
<fieldset><legend align=left>left</legend><p align=left>left p</fieldset>
<fieldset><legend align=center>center</legend><p align=center>center p</fieldset>
<fieldset><legend align=right>right</legend><p align=right>right p</fieldset>

http://software.hixie.ch/utilities/js/live-dom-viewer/saved/4196
This is a regression, probably from 'writing-mode' work.
Looks like an easy fix though...
Assignee: nobody → mats
Component: Layout → Layout: Form Controls
Keywords: regression
Note that 'writing-mode' isn't needed to trigger the bug,
<legend align=right> is broken in all writing modes.
Blocks: 1123133
Summary: <legend align=left/right> doesn't work in vertical writing-mode → <legend align=right> doesn't work
Attached patch fixSplinter Review
Attachment #8753764 - Flags: review?(jfkthame)
Comment on attachment 8753764 [details] [diff] [review]
fix

Review of attachment 8753764 [details] [diff] [review]:
-----------------------------------------------------------------

So the existing code just fails to handle align=right at all, except in the !IsBidiLTR() case... oops! Thanks for the fix, looks good.
Attachment #8753764 - Flags: review?(jfkthame) → review+
Yep, a specified 'right' just passed straight through into the default: case.

I think physical things are confusing. :-)
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/ab3f9ec8c8d2
https://hg.mozilla.org/mozilla-central/rev/45609552e6b0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.