Closed Bug 1273624 Opened 4 years ago Closed 4 years ago

Style rules are not displaying while inspecting remote runtimes.

Categories

(DevTools :: Inspector: Rules, defect, P1)

49 Branch
defect

Tracking

(firefox49 verified)

VERIFIED FIXED
Firefox 49
Iteration:
49.3 - Jun 6
Tracking Status
firefox49 --- verified

People

(Reporter: gregtatum, Assigned: pbro)

References

Details

(Keywords: regression, Whiteboard: [devtools-html])

Attachments

(2 files)

STR:
* Open up dev edition (Firefox 48)
* Listen on port 6000
* Open up Nightly (Firefox 49)
* Open up WebIDE connect to localhost:6000
* Inspect a tab
* All style rules will be gone from the inspector

No errors are reported when connecting to the tab and inspecting it. There is a deprecation notice when first loading WebIDE for protocol.js, but is probably unrelated.
Has Regression Range: --- → no
Has STR: --- → yes
I'll see if I can reproduce.  It suggests there's a backward compat gap.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Priority: -- → P1
It looks like this is a regression from bug 1069829, which added "declarations" to page style actor.

:pbro, it looks like the client does not properly handle old servers that are missing declarations in the reply.  Can you take a look?
Assignee: jryans → nobody
Blocks: 1069829
Status: ASSIGNED → NEW
Flags: needinfo?(pbrosset)
Keywords: regression
Priority: P1 → --
Whiteboard: [devtools-html] [triage]
Component: Developer Tools: WebIDE → Developer Tools: CSS Rules Inspector
Investigating now. I'll need to uplift the fix if I can't land it before the merge date (next Monday?)
Flags: needinfo?(pbrosset)
Ok, found the problem. Backward compatibility was handled, but there was a typo in the code. I must have tested it before, then changed some code and didn't test again, and of course it was broken, and since we don't have tests for this, I didn't realize.
I will post a patch soon.
Assignee: nobody → pbrosset
Status: NEW → ASSIGNED
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [devtools-html] [triage] → [devtools-html]
Comment on attachment 8759206 [details]
Bug 1273624 - Really check for existence of parsed declarations in StyleRuleActor's form for compatibility;

https://reviewboard.mozilla.org/r/57234/#review54030

Thanks for the quick fix!
Attachment #8759206 - Flags: review?(jryans) → review+
Flags: qe-verify? → qe-verify+
QA Contact: alexandra.lucinet
Pushed by pbrosset@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/952534db8d85
Really check for existence of parsed declarations in StyleRuleActor's form for compatibility; r=jryans
https://hg.mozilla.org/mozilla-central/rev/952534db8d85
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Iteration: --- → 49.3 - Jun 6
Priority: P2 → P1
Verified fixed FX 49.0a1 (2016-06-06) Win 7
Status: RESOLVED → VERIFIED
Also verified fixed on OS X 10.11, Ubuntu 14.04.
Whiteboard: [devtools-html] → [devtools-html], [qe-dthtml]
QA Whiteboard: [qe-dthtml]
Flags: qe-verify+
Whiteboard: [devtools-html], [qe-dthtml] → [devtools-html]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.