Set new cookie but the Expires is wrong by using "cookie list" on developer tool bar.

RESOLVED FIXED in Firefox 49

Status

()

Core
Networking: Cookies
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Amy, Assigned: Amy)

Tracking

47 Branch
mozilla49
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox49 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) 

Steps to reproduce:

Tested extensively in Firefox 47.0b6 on Mac OSX 10.10.5

1. Enter "www.example.com"
2. Used "cookie set test-1 test" on "Developer Toolbar".
3. Used "cookie list" to confirm cookie information, the expires showed "1/26/1970, 4:27:50 AM".
4. Double confirmed the cookie expires on storage, it showed "1/17/2038, 12:00:00 AM" on storage.
(Assignee)

Updated

a year ago
Whiteboard: [necko-active]
(Assignee)

Updated

a year ago
Assignee: nobody → amchung
(Assignee)

Comment 1

a year ago
Created attachment 8755211 [details] [diff] [review]
The cookie 'expires' value needs converting into something more readable.  And The unit of expires is sec, the unit that in argument of Date() needs millisecond.

Hi Jason,
I have modified the translateExpires() function in devtools/shared/gcli/commands/cookie.js.
Because unit that in argument of Date() needs millisecond.
Attachment #8755211 - Flags: review?(jduell.mcbugs)
Comment on attachment 8755211 [details] [diff] [review]
The cookie 'expires' value needs converting into something more readable.  And The unit of expires is sec, the unit that in argument of Date() needs millisecond.

Review of attachment 8755211 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch!
Attachment #8755211 - Flags: review?(jduell.mcbugs) → review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed
(Assignee)

Updated

a year ago
Keywords: checkin-needed
(Assignee)

Comment 3

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=dd46e3955520
(Assignee)

Comment 4

a year ago
Created attachment 8757266 [details] [diff] [review]
The cookie 'expires' value needs converting into something more readable.  And The unit of expires is sec, the unit that in argument of Date() needs millisecond.
Attachment #8755211 - Attachment is obsolete: true
(Assignee)

Comment 5

a year ago
Created attachment 8757268 [details] [diff] [review]
Modified the comment of translateExpires().
Attachment #8757266 - Attachment is obsolete: true
Attachment #8757268 - Flags: review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed

Comment 6

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/882e4cb1e069
Keywords: checkin-needed

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/882e4cb1e069
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox49: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.