Homepage URL does not default to http when entered manually

VERIFIED FIXED

Status

()

Firefox for iOS
General
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: jhugman)

Tracking

({reproducible})

unspecified
Other
iOS
reproducible

Firefox Tracking Flags

(fxios-v5.0 verified, fxios5.0+)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Using Nightly on TestFlight (https://github.com/mozilla/firefox-ios/commits/FirefoxNightly-v5.0b5)

=> Settings / Homepage Settings / 
=> Enter `mozilla.org`

There's no way to save/commit the URL entered.
Note:

- The entered URL can be saved by tapping on the '< Settings' button but only when typing the URL domain as well ( http://adress.com ). After typing the http:// domain the text color will change from red to black and the URL will  be saved. 
On Android, the address can be saved without having to enter http:// . Can we do the same on iOS?
(Assignee)

Updated

2 years ago
Assignee: nobody → jhugman
(Assignee)

Updated

2 years ago
Summary: Unable to manually set a custom homepage → Homepage URL does not default to http when entered manually
Rank: 5
tracking-fxios: ? → 5.0+
(Assignee)

Comment 2

2 years ago
Created attachment 8756296 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/1850
Attachment #8756296 - Flags: review?(bnicholson)
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
Comment on attachment 8756296 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/1850

I think we could simplify the a little as mentioned in the PR, but LGTM otherwise.
Attachment #8756296 - Flags: review?(bnicholson) → review+
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1276543
(Assignee)

Comment 5

2 years ago
Fixed and merged.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Verifying as fix on master 6ad4b686.
Status: RESOLVED → VERIFIED
status-fxios-v5.0: affected → verified
You need to log in before you can comment on or make changes to this bug.