Closed Bug 127451 Opened 20 years ago Closed 20 years ago

Image submit buttons should only submit form when mouse up occurs over image

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 53966

People

(Reporter: bugzilla, Assigned: alexsavulov)

References

()

Details

Using build 2002022203. 

Steps to Reproduce:

1. Go to http://www.bbc.co.uk/
2. Click and hold mouse button down over the "Go" image next to the search box
at the top of the page.
3. Move mouse away from the "Go" image, then release mouse button.

Actual results: Form is submitted.
Expected Results: Form is not submitted.

The form should only be submitted if the mouse up occurs over the submit image.
This is the case with normal, non-image submit buttons.
jkeiser, don't we submit onClick?  We shouldn't be getting an onClick event if
the mouseup is off the image....

*** This bug has been marked as a duplicate of 53966 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verifying dup
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.