Closed Bug 1274539 Opened 3 years ago Closed 3 years ago

reftests shadow dom "display: contents" with blue are failing?

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox50 fixed)

RESOLVED FIXED
Tracking Status
firefox50 --- fixed

People

(Reporter: gerard-majax, Assigned: wchen)

References

Details

(Whiteboard: fixed-in-pine)

Attachments

(1 file)

Blocks: 1267321
William, do you have any idea?
Flags: needinfo?(wchen)
The reftest e10s s2 and s3 errors on opt and debug are the same as those.
ok, it seems to relates to shadow dom + display: contents more than the color. Reverting the only pine-specific patch we have regarding ShadowRoot does not help.
Flags: needinfo?(wchen)
William, I am not able to see any difference between central and pine touching either the related prefs, or ShadowDOM or CSS :/ Can you help?
Flags: needinfo?(wchen)
Yeah, it's really strange that these tests are failing if the Shadow DOM platform code hasn't been changed. I'll look into it.
Flags: needinfo?(wchen)
It looks like the failures is caused by this patch:

http://hg.mozilla.org/projects/pine/rev/e417ce4b94e4

That patch traverses across the shadow root when getting the parent node that is added to the undisplayed map. The problem is that we don't do the same when we do a lookup in some other code so we end up using the wrong key in the map lookup.

This patch should fix the test failures you are seeing.
Assignee: nobody → wchen
That's surprising, this is a patch I tested reverting, and I was still having the issue :/
Ok, I got lurred by antialiasing :/
Blocks: 1261351
Thanks William, all reftests are green!
Flags: needinfo?(wchen)
Comment on attachment 8757117 [details] [diff] [review]
Use GetParentCrossingShadowRoot() instead of GetParent() in GetStyleContextInMap when looking up undisplayed nodes

You should probably also add the MOZ_ASSERT(parent || !aContent->GetParent(), "no non-elements"); that Kyle's patch has.

And this should land at the same time as bug 1261351.

r=dbaron
Attachment #8757117 - Flags: review+
Pushed by wchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/daecf88f0427
Use GetParentCrossingShadowRoot() instead of GetParent() in GetStyleContextInMap when looking up undisplayed nodes. r=dbaron
https://hg.mozilla.org/mozilla-central/rev/daecf88f0427
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(wchen)
You need to log in before you can comment on or make changes to this bug.