Closed Bug 1274589 Opened 4 years ago Closed 4 years ago

Rename RegionBuilder::Or to RegionBuilder::OrWith

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: kats, Assigned: kats)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
For consistency with nsRegion/nsIntRegion, the RegionBuilder::Or function should be renamed, as tnikkel pointed out at https://bugzilla.mozilla.org/show_bug.cgi?id=1274397#c1. On the region classes, the Or function takes two arguments and ors them together, replacing the currently-stored region. The OrWith function ors the given argument into the current-stored region.
Attachment #8754848 - Flags: review?(bgirard)
Attachment #8754848 - Flags: review?(bgirard) → review+
Late r+
https://hg.mozilla.org/mozilla-central/rev/6a6cf1f4f7c2
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.