Unexpected property "browser_style" prevents extension installation

RESOLVED DUPLICATE of bug 1244474

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1244474
2 years ago
2 years ago

People

(Reporter: Jan Biniok, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/50.0.2661.102 Chrome/50.0.2661.102 Safari/537.36

Steps to reproduce:

Install FF 47.0b7
Try to install Tampermonkey from here https://addons.mozilla.org/en-US/firefox/addon/tampermonkey


Actual results:

1463767750747	addons.webextension.<unknown>	ERROR	Loading extension 'null': Reading manifest: Error processing browser_action: Unexpected property "browser_style"
1463767750789	addons.xpi	WARN	Download of https://addons.mozilla.org/firefox/downloads/latest/683490/addon-683490-latest.xpi?src=dp-btn-primary failed: Error: Extension is invalid (resource://gre/modules/addons/XPIProvider.jsm:875:11) JS Stack trace: loadManifestFromWebManifest<@XPIProvider.jsm:875:11 < TaskImpl_run@Task.jsm:319:40 < Handler.prototype.process@Promise-backend.js:937:23 < this.PromiseWalker.walkerLoop@Promise-backend.js:816:7 < this.PromiseWalker.scheduleWalkerLoop/<@Promise-backend.js:750:11



Expected results:

The extension should be installed

Note: it's working fine with FF 46.0.1 and 48.0a2 (2016-05-20)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 1244474
You need to log in before you can comment on or make changes to this bug.