Browser toolbox: debugger source list is empty after switching to a frame

RESOLVED DUPLICATE of bug 1346902

Status

P3
normal
RESOLVED DUPLICATE of bug 1346902
2 years ago
4 months ago

People

(Reporter: wbamberg, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox49 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8755046 [details]
toolbox.mp4

I'm documenting using the Browser toolbox to debug WebExtensions.

You can use it to debug persistent JS sources like background scripts, just by switching to the Debugger, and finding the add-on code in the source list (or using search:

https://developer.mozilla.org/en-US/Add-ons/WebExtensions/Debugging#Debugging_JavaScript

You can also use it for inspecting popups:
* disable autohide
* open the popup
* use the frame selection to switch to the popup's document
* inspect the popup in the inspector

But, once you've switched to the popup's document, the Debugger source view becomes empty, saying "This page has no sources". Even after you switch back to the main browser.xul document, it stays empty.
Component: Developer Tools → Developer Tools: Debugger
(Reporter)

Comment 1

2 years ago
...after you've been through the steps above, and you're looking at an empty source listing, if you then dismiss the popup, a few sources appear in the Debugger's source list, namely these ones:

chrome://browser
    panelUI.xml
chrome://global
    browser.xml
    popup.xml

and this: "(function (contentFrame, PATH) {  let { registerContentFrame } = Components.utils.import(PATH + 'framescript/content.jsm', {});  registerContentFrame(contentFrame);})(this, "resource://gre/modules/commonjs/");"

If you then reopen the popup, its source file reappears.

Updated

2 years ago
Priority: -- → P3

Comment 2

2 years ago
This issue seems to be specific of the old Debugger UI, while the new Debugger UI seems to correctly refresh the list of the sources when we switch between the available listed frames.

I'm duping this with Bug 1346902, which has switched on the new Debugger UI for both the Browser Toolbox and the Addon Debugging toolbox.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1346902

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.