Network Monitor: 'Response' tab gives SyntaxError for valid JSON request

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
3 years ago
4 months ago

People

(Reporter: nachtigall, Unassigned)

Tracking

48 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:48.0) Gecko/20100101 /
Build ID: 20160519004038

Steps to reproduce:

1. Open Network Monitor
2. Open a valid JSON like http://nominatim.openstreetmap.org/search?q=135+pilkington+avenue,+birmingham&format=json&polygon=1&addressdetails=1
3. Click on Response tab

See screenshot.


Actual results:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data. 
(BTW: Would be appreciated if error messages like this could be selected and copied, e.g. to do a quick google search or similar - now I needed to retype it manually)

Happens in Dev Edition and Nightly.

Maybe related to Bug 923856


Expected results:

Show formatted json.
(Reporter)

Updated

3 years ago
See Also: → bug 923856
(Reporter)

Comment 1

3 years ago
Maybe it's an encoding problem? At least the console's net output under 'Response' only show garbage, see new screenshot
Reproducible with latest nightly in windows-10.

---
Version 	49.0a1
Build ID 	20160526030223
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Netmonitor
Ever confirmed: true
Thanks for the report!

I can also see the problem. Btw. the JSON Viewer (if enabled in about:config devtools.jsonview.enabled) works well so, it really might be just encoding problem.

Honza
Priority: -- → P2

Updated

10 months ago
Product: Firefox → DevTools
I can't reproduce this problem in Firefox 65 (Nightly)

Closing, but feel free to reopen (or ping me) if you are still seeing it.

Thanks for the help!
Honza
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.