WebRTC: Networking -> Firefox does not detect TURN Relay through corporate network

RESOLVED DUPLICATE of bug 1203503

Status

()

Core
WebRTC: Networking
P2
normal
Rank:
25
RESOLVED DUPLICATE of bug 1203503
2 years ago
2 years ago

People

(Reporter: Seampl, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36

Steps to reproduce:

Case1: Through Home network (without Proxy, Firewall,.. ) it is working

Case2: Through Corporate network, it is not working. We have signaling but not voice


Actual results:

In case 2; TURN Relay not discovered
We are using https://webrtc.github.io/samples/src/content/peerconnection/trickle-ice/ to check if our TURN address is in. but it is not


Expected results:

Our TURN should be listed
Voice should be working
(Reporter)

Comment 1

2 years ago
It is working on chrome

Updated

2 years ago
backlog: --- → webrtc/webaudio+
Rank: 25
Priority: -- → P2
Can you please attach a copy of about:webrtc after executing the second failed case from your corporate network?
Flags: needinfo?(arnaud)
Whiteboard: [needinfo 2016/05/24 to reporter]
(Reporter)

Comment 3

2 years ago
Created attachment 8756958 [details]
log FF tcp 80 working.png

please find logs when it was not working. thanks
We are available for more try
thanks
A
(Reporter)

Comment 4

2 years ago
The version is firefox 47.0b.7.
Thanks for attaching the screen shot, but I really need the full log file.
If you don't want to share log here in the public bug, please send them to me directly via email.

Just to be safe:
- start a fresh Firefox
- open https://webrtc.github.io/samples/src/content/peerconnection/trickle-ice/ and add your TURN server
- once done open about:webrtc and click the "Save Page" button in the upper left corner
- send me the resulting page
Whiteboard: [needinfo 2016/05/24 to reporter] → [needinfo 2016/05/26 to reporter]
Arnau provided me with logs via email which show that his proxy requires authentication. Closing as dupe therefore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1203503

Updated

2 years ago
Flags: needinfo?(arnaud)
Whiteboard: [needinfo 2016/05/26 to reporter]
You need to log in before you can comment on or make changes to this bug.