Closed Bug 1275401 Opened 5 years ago Closed 5 years ago

mach bootstrap installs build tools 23.0.3 rather than 23.0.1

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1247047

People

(Reporter: mcomella, Assigned: mcomella)

Details

irc, this afternoon:
14:05 <dlim> mcomella: hi, i was bootstraping with the python script for firefox for android and the output of the script showed buildtools revision 23.0.1 has been installed. However, when i ran the build script it failed with the message that buildtools revision 23.0.1 wasn't installed. I checked the android SDK manager and it turns out buildtools revision 23.0.3 has
14:05 <dlim> been installed instead. Am i missing something?

Likely workaround:
14:07 <mcomella> dlim: Do you have the option of installing 23.0.1?
14:10 <dlim> ah i see, yeah i could install it manually through the SDK manager
14:12 <mcomella> dlim: k, do that for now and I'll look into this on the side

Explanation:
14:08 <mcomella> dlim: fwiw, what usually happens is Google will update the SDK, remove the old dependencies, and we have to update our builds (and it sucks :( )
Sebastian said he was updating the dependencies in bug 1247047 so I'm not going to invest in this at the moment.

I wrote up my understanding of the SDK dependencies if anyone needs to update how we handle them in the future: https://wiki.mozilla.org/Mobile/Fennec/Android/SDK_dependencies
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247047
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.