Apparently non-fatal Windows opt TEST-UNEXPECTED-PASS in js1_5\extensions\toLocaleFormat-02.js

RESOLVED DUPLICATE of bug 818634

Status

()

defect
RESOLVED DUPLICATE of bug 818634
3 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

(Reporter)

Description

3 years ago
Two issues here:
* toLocaleFormat-02.js apparently passes unexpectedly on Windows opt
* It's not fatal that it does?!

https://treeherder.mozilla.org/logviewer.html#?job_id=28620631&repo=mozilla-inbound#L49151

TEST-UNEXPECTED-PASS | js1_5\extensions\toLocaleFormat-02.js | (args: "--baseline-eager --no-fpu")
TEST-UNEXPECTED-PASS | js1_5\extensions\toLocaleFormat-02.js | (args: "--no-baseline --no-ion")
TEST-UNEXPECTED-PASS | js1_5\extensions\toLocaleFormat-02.js | (args: "--baseline-eager")
TEST-UNEXPECTED-PASS | js1_5\extensions\toLocaleFormat-02.js | (args: "--ion-eager --ion-offthread-compile=off --non-writable-jitcode --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads")
TEST-UNEXPECTED-PASS | js1_5\extensions\toLocaleFormat-02.js | (args: "")
TEST-UNEXPECTED-PASS | js1_5\extensions\toLocaleFormat-02.js | (args: "--ion-eager --ion-offthread-compile=off")
Not that I pay attention to my needinfo queue, but ni?me because it's ungood. And I think I noticed it for something else not long ago.
Flags: needinfo?(sphink)
The first line is:

// |reftest| fails-if(xulRuntime.OS=="WINNT") skip-if(xulRuntime.OS=="WINNT"&&isDebugBuild)

...so it expects to fail in an opt build, and is skipped entirely in a debug build (Windows only).
Flags: needinfo?(sphink)
toLocaleFormat was removed in bug 818634.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818634
You need to log in before you can comment on or make changes to this bug.