Closed Bug 1275486 Opened 8 years ago Closed 7 months ago

nsLookUpDictionaryCommand::DoCommandParams should use context breaker if possible

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1719535
Tracking Status
firefox49 --- affected

People

(Reporter: m_kato, Unassigned)

References

Details

(Whiteboard: btpp-backlog)

From bug 1177943 comment #18 and bug 1212527 comment 21

> Our current implementation of WordBreaker won't work for languages like
> Chinese or Japanese. I guess it is probably fine for an initial version, but
> we would eventually want to use the framework Apple provides (see
> bug 1212527 comment 21), so that we have the identical behavior as native
> apps.

So we consider that nsLookUpDictionaryCommand::DoCommandParams uses use context based breaker by OS API...
Whiteboard: btpp-backlog
Blocks: 301451
Priority: -- → P3
Component: DOM → DOM: Core & HTML
Severity: normal → S3

Makoto, do we need to do anything on this bug after we use ICU4X word segmenter? Three finger tap on my macOS seems correctly select a word in Chinese with a dictionary popup.

Flags: needinfo?(m_kato)

Original issue is that we should consider ICU based word segmenter instead of our word segmenter to select better word. But we move to ICU4X's dictionary for CJ, so this is dup of bug 1719535

Status: NEW → RESOLVED
Closed: 7 months ago
Duplicate of bug: 1719535
Flags: needinfo?(m_kato)
Resolution: --- → DUPLICATE

(macOS's word selector seems to use ICU4C)

You need to log in before you can comment on or make changes to this bug.