Closed Bug 1275703 Opened 3 years ago Closed 3 years ago

AEC is off in second and later getUserMedia() calls

Categories

(Core :: WebRTC: Audio/Video, defect, P1, critical)

defect

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

Attachments

(2 files)

After starting and stopping a getUserMedia audio capture, on the next getUserMedia call the AEC (and NS/AGC) will all be off, because we release the VoiceEngine but don't clear our copy of the state of the engine.

This patch removes the copy of the state entirely.  Researching shows that this ends up in ProcessingComponent::EnableComponent(bool enable), which does "if (enable && !enabled_)", so re-enabling has no effect - thus our paranoia about re-enabling resetting the AEC is unfounded.

This was caused by bug 1273206
MozReview-Commit-ID: CyOhSa3dOSU
Attachment #8756518 - Flags: review?(jib)
Comment on attachment 8756518 [details] [diff] [review]
remove saved state about configuration of the VoiceEngine

Review of attachment 8756518 [details] [diff] [review]:
-----------------------------------------------------------------

Lgtm, though mEchoCancel, mAGC and mNoiseSuppress appear unused, and can be removed as well AFAICT. That should simplify further.
Attachment #8756518 - Flags: review?(jib) → review+
MozReview-Commit-ID: 1e86oZWUGeq
Attachment #8756551 - Flags: review?(jib)
Comment on attachment 8756551 [details] [diff] [review]
remove the rest of the saved state

Review of attachment 8756551 [details] [diff] [review]:
-----------------------------------------------------------------

Less is more.
Attachment #8756551 - Flags: review?(jib) → review+
Rank: 10
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/eff54d521d78
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.