address some more crashes related to d3d11 dxva in 47.0b8

RESOLVED FIXED in Firefox 47

Status

()

defect
P1
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: philipp, Assigned: philipp)

Tracking

({crash, regression})

47 Branch
mozilla49
All
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 unaffected, firefox47 fixed, firefox48 fixed, firefox49 fixed)

Details

(crash signature)

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1274132 +++

adding a couple of more dll versions to the blacklist based on data from 47.0b8:

igd10iumd32.dll
igd11dxva32.dll@0x2549b6 -> 10.18.15.4248
igd10iumd32.dll@0x2aade6 -> 10.18.10.3958
TppValidateCleanupGroupMember -> 10.18.10.3496
igd10iumd32.dll@0x3e2cfe -> 9.18.10.3006

igd10umd32.dll
@0x0 | igd10umd32.dll@0x17874f -> 9.17.10.3040

atidxx32.dll
atidxx32.dll@0x74527 -> 8.17.10.531
RtlpFreeHeap | RtlFreeHeap | atiumdva.dll@0x1328a8 -> 8.17.10.453

nvwgf2um.dll
RtlpLowFragHeapAllocFromContext | RtlpAllocateHeapInternal | RtlAllocateHeap | nvwgf2um.dll@0x909fb2 -> 10.18.13.6510
nvwgf2um.dll@0xbfce -> 9.18.13.4195
Assignee: nobody → madperson
Attachment #8756584 - Flags: review?(gsquelart)
I find this highly suspicious all those dlls crashing. How well are they doing with other program?

Are they also blacklisted in chrome?

Could it just be due to the way we are using d3d11 in our code?
Comment on attachment 8756584 [details] [diff] [review]
bug1275739.patch

Review of attachment 8756584 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you for finding these.
Attachment #8756584 - Flags: review?(gsquelart) → review+
(In reply to Jean-Yves Avenard [:jya] from comment #2)
> I find this highly suspicious all those dlls crashing. How well are they
> doing with other program?
> 
> Are they also blacklisted in chrome?
> 
> Could it just be due to the way we are using d3d11 in our code?

I agree that it could very well be our use that's somehow incorrect, but Chris and I thought it'd still be worth trying to reduce crash reports quickly before the 47 release.
Having blacklisted DLLs in a pref allows us & others to easily re-enable these drivers for local debugging.
Comment on attachment 8756584 [details] [diff] [review]
bug1275739.patch

Approval Request Comment
[Feature/regressing bug #]: bug 1248496
[User impact if declined]: firefox crashes on media playback for users of certain graphics drivers
[Describe test coverage new/current, TreeHerder]: none
[Risks and why]: low; this makes use of the purpose-built blacklisting pref from  bug 1273691 which landed in 47.0b8 and worked well there. the patch is just covering a few more crashy dll versions that surfaced in 47.0b8 crash data
[String/UUID change made/needed]: none
Attachment #8756584 - Flags: approval-mozilla-beta?
Attachment #8756584 - Flags: approval-mozilla-aurora?
Keywords: checkin-needed
This is something we *do* want fixed in Fx47 as this is related to release blocking bug 1270686.
Comment on attachment 8756584 [details] [diff] [review]
bug1275739.patch

This fix is meant to help with a potentially release blocking startup crash. Aurora48+, Beta47+
Attachment #8756584 - Flags: approval-mozilla-beta?
Attachment #8756584 - Flags: approval-mozilla-beta+
Attachment #8756584 - Flags: approval-mozilla-aurora?
Attachment #8756584 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/ff7e1d26cbea
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.