Seccomp sandbox violation: sys_accept called in content process of Firefox desktop

RESOLVED FIXED in Firefox 49

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: tedd, Assigned: tedd)

Tracking

unspecified
mozilla49
Points:
---

Firefox Tracking Flags

(firefox49 fixed)

Details

(Whiteboard: sblc1)

Attachments

(2 attachments)

Running tests on try with seccomp enabled [1] hit a seccomp violation by using sys_accept()

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=b74081e971fd&selectedJob=21341876
(Assignee)

Comment 2

3 years ago
For now, in order to get seccomp enabled on nightly, I think we should whitelist this and try to figure out later how we can reduce the system calls for the socket API.
Attachment #8757321 - Flags: review?(jld) → review+
It looks like this was caused by a test that runs httpd.js in a content process, but only because it needs a custom httpd to run *somewhere*, and it wasn't written with sandboxed e10s in mind.  (It also can't ever have worked on B2G.)  There should be a followup bug for that.
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 5

3 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/25abbc9e6237
Add sys_accept to seccomp whitelist. r=jld
Keywords: checkin-needed

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/25abbc9e6237
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.