Closed Bug 1275857 Opened 6 years ago Closed 6 years ago

[Synced Tabs Sidebar] Not all synced tabs are displayed in Synced Tabs Sidebar on a second device

Categories

(Firefox :: Sync, defect, P3)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox47 --- wontfix
firefox48 --- affected
firefox49 --- affected

People

(Reporter: cbadau, Unassigned)

Details

Attachments

(1 file)

Attached image issue.png
[Affected versions]:
- Firefox 49.0a1 
- Firefox 48.0a2
- Firefox 47 Beta 8 

[Affected platforms]:
- Windows 7 64bit
- Mac OS X 10.9.5 
- Ubuntu 14.04 64bit

[Steps to reproduce]:
1. Login on 2 devices/profiles with the same Firefox account.
3. On first device/profile, open multiple different tabs (100 tabs). 
4. From Menu Bar > Tools select the "Sync Now" option to perform a sync.  
5. Open Synced Tabs Sidebar on the second device/profile and perform a sync ("Sync now"). 

[Expected result]:
- All the tabs opened on the first device/profile are displayed in the Synced Tabs Sidebar under the first device/profile name.

[Actual result]:
- Not all synced tabs are displayed in the Synced Tabs Sidebar on second device. Please see attached screenshot "issue.png" (If I have on first device opened 100 different google searches in different tabs, on second device, after sync, only 78-82 synced tabs are displayed in Synced Tabs Sidebar). 

[Regression range]:
- This is a regression since it isn't reproducible on Nightly 01-26-2016 (the build when the Synced Tabs Sidebar was implemented). I'll provide as soon as possible the regression range.
Hello Kit, Mark, could you please help investigate this issue? If 100% reproducible, this might block Fx47 release.
Flags: needinfo?(markh)
Flags: needinfo?(kcambridge)
Hello Camelia, could you please provide a regression range for this bug? Given that we are 2 days away from RC week, the sooner we can root cause this to a patch that regressed it the better. Thanks!
Flags: needinfo?(camelia.badau)
This is not a regression.

The code that sends tabs from a device has a fixed payload size of 20k and it only sends as many tabs as can fit. This size depends on a number of things, including the length of each URL, so the actual maximum number of tabs isn't fixed, the number of bytes they take up is.

The code that does this is at https://dxr.mozilla.org/mozilla-central/rev/8d0aadfe7da782d415363880008b4ca027686137/services/sync/modules/engines/tabs.js#222 and was implemented in bug 535326 in 2010.
Flags: needinfo?(markh)
Flags: needinfo?(kcambridge)
(FWIW though, there probably is scope to increase this limit if it was considered worthwhile, but AFAIK a user has never reported this as an issue)
Thanks Mark for a quick investigation on this one. This is something we will ship Fx47 with and is not a release blocker.
Removed ni? based on comment 3 (regression range no longer needed).
Flags: needinfo?(camelia.badau)
Flags: firefox-backlog+
Priority: -- → P3
INVALID as this is working as intended.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.