Closed Bug 1275911 Opened 3 years ago Closed 3 years ago

get releng automation posting to cloudops balrog stage instance

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox49 fixed)

RESOLVED FIXED
Tracking Status
firefox49 --- fixed

People

(Reporter: bhearsum, Assigned: aselagea)

References

Details

Attachments

(1 file)

Now that the CloudOps Balrog is up and running at https://balrog-admin.stage.mozaws.net, we should get automation pointing to it to help validate it. Nightly builds are probably enough.
Assignee: nobody → aselagea
Not sure if this is all that is needed as I'm not pretty familiar with balrog.
Attachment #8757274 - Flags: feedback?(bhearsum)
Comment on attachment 8757274 [details] [diff] [review]
[m-c]bug_1275911.patch

Review of attachment 8757274 [details] [diff] [review]:
-----------------------------------------------------------------

This looks like it should work!
Attachment #8757274 - Flags: review+
Attachment #8757274 - Flags: feedback?(bhearsum)
Attachment #8757274 - Flags: feedback+
https://hg.mozilla.org/mozilla-central/rev/13ff741f383d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8757274 [details] [diff] [review]
[m-c]bug_1275911.patch

Benson asked that we postpone this until he gets the "try" environment up. I'm going to back this out for now. Should reland later this week.
Attachment #8757274 - Flags: checked-in+ → checked-in-
Pushed by bhearsum@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/84625e254651
get releng automation posting to cloudops balrog stage instance. r=bhearsum
Comment on attachment 8757274 [details] [diff] [review]
[m-c]bug_1275911.patch

(In reply to Ben Hearsum (:bhearsum) from comment #7)
> Comment on attachment 8757274 [details] [diff] [review]
> [m-c]bug_1275911.patch
> 
> Benson asked that we postpone this until he gets the "try" environment up.
> I'm going to back this out for now. Should reland later this week.

Turns out this isn't coming up until later. I've relanded this to inbound.
Attachment #8757274 - Flags: checked-in- → checked-in+
This made it into the latest nightly, and started failing with SSL verify errors. This is beacuse our Balrog submission code uses a ca bundle that we manage, and the DigiCert intermediary that the new stage environment is signed with was not in there. I fixed that in https://hg.mozilla.org/build/tools/rev/4c37d4d91156.

I'm a little confused as to why having the ultimate DigiCert root in the bundle wasn't enough, but maybe I just don't quite understand how SSL verification works.
(In reply to Ben Hearsum (:bhearsum) from comment #11)
> This made it into the latest nightly, and started failing with SSL verify
> errors. This is beacuse our Balrog submission code uses a ca bundle that we
> manage, and the DigiCert intermediary that the new stage environment is
> signed with was not in there. I fixed that in
> https://hg.mozilla.org/build/tools/rev/4c37d4d91156.
> 
> I'm a little confused as to why having the ultimate DigiCert root in the
> bundle wasn't enough, but maybe I just don't quite understand how SSL
> verification works.

Following up here, the SSL verify errors were caused by the server not returning the full cert chain.

We also hit connection reset errors on Windows and Mac which were resolved by enabling TLS1.0 on the server - our mac and windows machines are so old they need it :(.
Comment on attachment 8757274 [details] [diff] [review]
[m-c]bug_1275911.patch

Now that we're in prod, I've backed this out to avoid the problems talked about in bug 1261346.
Attachment #8757274 - Flags: checked-in+ → checked-in-
Backout by bhearsum@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3f17d5b2389
Backout now that we're done testing the new Balrog environment. r=me
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.