Sync doesn't remember password/login credentials

RESOLVED DUPLICATE of bug 1295122

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 1295122
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8757211 [details]
sync log

Reported by a user on IRC who sync several devices. Only a device with Firefox 46.0.1 on Lubuntu 14.04.3 LTS causes the issue.

Firefox forgets the login information for Sync and asks again for them. After the user enters them, the data gets synced. The issue started recently.

From the attached log:
> Sync.ErrorHandler	DEBUG	passwords failed: TypeError: Services.logins is undefined (resource://gre/modules/services-sync/engines/passwords.js:161:9) JS Stack trace: PasswordStore.prototype.getAllIDs@passwords.js:161:9 < SyncEngine.prototype._syncStartup@engines.js:921:22 < SyncEngine.prototype._sync@engines.js:1529:7 < WrappedNotify@util.js:146:21 < Engine.prototype.sync@engines.js:666:5 < _syncEngine@enginesync.js:213:7 < sync@enginesync.js:163:15 < onNotify@service.js:1279:7 < WrappedNotify@util.js:146:21 < WrappedLock@util.js:101:16 < _lockedSync@service.js:1269:12 < sync/<@service.js:1261:14 < WrappedCatch@util.js:75:16 < sync@service.js:1249:5

That seems to be this code:
>    getAllIDs: function () {
>    let items = {};
>    let logins = Services.logins.getAllLogins({});

Does it run in a context where Services.jsm hasn't been imported?
Almost certainly an addon - see bug 1166571
Bug 1295122 is tracking Services.logins is undefined
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1295122
You need to log in before you can comment on or make changes to this bug.