If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

E-mail search crashes on SMP system (in timer code)

VERIFIED DUPLICATE of bug 118004

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 118004
16 years ago
9 years ago

People

(Reporter: Julien Pierre, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When I do a search in all subfolders in mozilla 0.9.8 (milestone), the browser
crashes.

Here are the excerpts from popuplog.os2 :

------------------------------------------------------------

02-24-2002  23:22:44  SYS3175  PID 0039  TID 0001  Slot 008e
E:\INTERNET\MOZILLA\BIN\MOZILLA.EXE
c0000005
00000001
P1=00000001  P2=00000001  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00e65ad4  EBX=00e651b0  ECX=00e65ea8  EDX=01d87250
ESI=00354110  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00000001  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0013195c  SSACC=f0f3  SSLIM=ffffffff
EBP=001319c8  FLG=00210206

------------------------------------------------------------

02-24-2002  23:26:13  SYS3175  PID 0046  TID 0001  Slot 0090
E:\INTERNET\MOZILLA\BIN\MOZILLA.EXE
c0000005
00000001
P1=00000001  P2=00000001  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=014c141c  EBX=014c1688  ECX=014c16d8  EDX=0124b950
ESI=00354110  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00000001  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0013195c  SSACC=f0f3  SSLIM=ffffffff
EBP=001319c8  FLG=00210202

------------------------------------------------------------

02-24-2002  23:29:31  SYS3175  PID 0056  TID 0001  Slot 008f
E:\INTERNET\MOZILLA\BIN\MOZILLA.EXE
c0000005
00000001
P1=00000001  P2=00000001  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=0144332c  EBX=01443598  ECX=014435e8  EDX=0106aaa0
ESI=00354110  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:00000001  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0013195c  SSACC=f0f3  SSLIM=ffffffff
EBP=001319c8  FLG=00210202

I have determined that this crash only occurs on SMP.
I did this by copying MOZILLA.EXE to MOZUNI.EXE, and then using the IBM-supplied
EXECMODE tool to mark the binary as uniprocessor only. This forces all threads
in the program to run on the same processor.


[e:\internet\mozilla\bin]execmode mozuni.exe

ExecMode v1.0 - Single processor execution mode utility

ACTIVATED OPTIONS:
 SINGLE-PROCESSOR files option.

FILES MODIFIED:
 mozuni.exe (modified)

 1 file analyzed, 1 file MODIFIED.


After I do this, I can do searches, and the crash no longer occurs.
In order to determine whether this is an OS/2-only bug, somebody would have to
test this on another operating system that dispatches threads of the same
program to different CPUs.
Even then, the bug might or might not show up depending on the OS scheduler.

IMHO, this is probably an XP bug due to a thread-safety issue the in Mozilla
mail/news code, which is only triggered on SMP. This is especially true because
I'm running Mozilla on a very fast system - dual Athlon MP 1500+, running OS/2 SMP.
(Reporter)

Comment 1

16 years ago
FYI, no crash occurs if I use the original binary, marked SMP-capable, but
disable the second CPU completely on the machine using MPCPUMON.
It only happens with the two CPUs enabled and the original binary marked SMP
capable.

From what I can see, the search is complete - there are matches displayed in the
search window - and then the crash occurs. It may be a race condition/thread
synchronization problem.

I tried to reproduce the probl. on my system in Win2K, but couldn't even get the
4.x profile migrated there, so I couldn't do the search.

I don't know if it's relevant but I have about 600 MB of email in my database.
Given the speed the search happens, I think only some indexes are being searched
rather than the whole database.
Summary: E-mail search crashes on SMP → E-mail search crashes on SMP system

Comment 2

16 years ago
FWIW: I'm seeing this pretty much everytime I do a e-mail
search on recent cvs builds on Linux SMP. When I reboot
to a UP kernel, the problem goes away. I've spent quite a 
bit of time tracking down a possible cause, and I think I've
found a race condition in the timer code - see bug 118004
for details (seemed like a more appropriate place, since
the stack trace in that bug matches what I'm getting, but
the trigger for me is always e-mail search).

(Reporter)

Updated

16 years ago
OS: OS/2 → All
Hardware: PC → All
(Reporter)

Updated

16 years ago
Depends on: 118004
this is a dup.

we've got a bunch (at least 3) bugs about crashing on quick search on multi 
processor systems.

looks like rich william is onto something, working on this with kerz right now.
Assignee: naving → sspitzer
Summary: E-mail search crashes on SMP system → E-mail search crashes on SMP system (in timer code)
No longer depends on: 118004
dup.  but good news, brendan has a fix.

*** This bug has been marked as a duplicate of 118004 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: nsbeta1+
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla1.0

Comment 5

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

9 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.