Reps: uninteresting props are not filtered correctly

RESOLVED DUPLICATE of bug 1282791

Status

RESOLVED DUPLICATE of bug 1282791
2 years ago
3 months ago

People

(Reporter: linclark, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox49 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
If you have a Rep like grip and it has uninteresting properties, these should be filtered in the preview. However, right now they are not. See Bug 1264685 comment #4.

Test object

> {a: undefined, b: undefined, c: "c", d: 1}

Actual result:

> {a: undefined, b: undefined, c: "c", more...}

Expected result:

> {c: "c", d: 1, a: undefined, more...}

Optimal result:

> {a: undefined, c: "c", d: 1, more...}
(Reporter)

Updated

2 years ago
Whiteboard: [devtools-html] [triage]

Updated

2 years ago
Blocks: 1263741

Updated

2 years ago
Priority: -- → P2
Whiteboard: [devtools-html] [triage] → [devtools-html]

Updated

2 years ago
Priority: P2 → P3
Whiteboard: [devtools-html] → [reserve-html]
Hi Honza,

Based on the discussion in Bug 1264685 comment #4. It seems like you would prefer to treat all the object as uninteresting props. Just want to confirm that:
- Is it possible to have a property that doesn't belong to bool/number/string/object? Because even the null/undefined value would be wrap as object in the grip.
- Should we treat all the object as uninteresting, or we need to check the value and classify it as uninteresting only if undefined/null?
Flags: needinfo?(odvarko)
Created attachment 8771896 [details] [diff] [review]
bug-1276376.patch

Looks like we could revise testUninterestingProps in this way, but I'm not sure whether we should add long mode test for a grip exceed the long max length.
(In reply to Steve Chung [:steveck] from comment #1)
> Hi Honza,
> 
> Based on the discussion in Bug 1264685 comment #4. It seems like you would
> prefer to treat all the object as uninteresting props. Just want to confirm
> that:
> - Is it possible to have a property that doesn't belong to
> bool/number/string/object? Because even the null/undefined value would be
> wrap as object in the grip.
There might be a `Symbol` (new in ECMAScript 6), but I didn't test it yet.

> - Should we treat all the object as uninteresting, or we need to check the
> value and classify it as uninteresting only if undefined/null?
We should treat objects as uninteresting. So, null, undefined and object is all uninteresting.


(In reply to Steve Chung [:steveck] from comment #2)
> Created attachment 8771896 [details] [diff] [review]
> bug-1276376.patch
> 
> Looks like we could revise testUninterestingProps in this way, but I'm not
> sure whether we should add long mode test for a grip exceed the long max
> length.
Good question, please create another report for it.

Honza
Flags: needinfo?(odvarko)

Comment 4

2 years ago
Hi Honza,

Looks like the bug is a duplicate of Bug 1282791. If so, let's set as duplicate.
Flags: needinfo?(odvarko)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(odvarko)
Resolution: --- → DUPLICATE
Duplicate of bug: 1282791

Updated

2 years ago
No longer blocks: 1263741
Priority: P3 → --
Whiteboard: [reserve-html]

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.