Opening Plain Text Message Draft adds additional leading blank in text line starting with leading blanks

NEW
Unassigned

Status

--
major
2 years ago
2 years ago

People

(Reporter: RainerBielefeldNG, Unassigned)

Tracking

({regression, regressionwindow-wanted})

SeaMonkey 2.43 Branch
Unspecified
All
regression, regressionwindow-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [easyconfirm])

Attachments

(1 attachment)

1.69 KB, application/save-as
Details
(Reporter)

Description

2 years ago
Created attachment 8757598 [details]
test kit

Steps how to reproduce with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit:

0. download and unzip attached testkit.zip
1. Launch SeaMonkey email client
2. Click on inbox of arbitrary email account with preference 
   "Compose as Plain Text" → Click 'Compose' icon to compose new email
   » Email composer opens with new empty email
3. From Testkit open "Test Text.txt" in Text editor (I use SynWrite)
4. Select all Text and copy / paste to email body
5. Type Subject "Draft0001"
6. 'Icon Save▼ → As Draft'
7. Click left from word "tell" in second line
   » Caret flashes left from "tell"
8. Press <arrowup> on keyboard
   » Caret flashes directly behind "If"
9. Close Email Composition Window with click on Close-X at top right
   window corner
10. Reopen saved "Draft0001" by double click
11. Redo test from stepx 7,8
    Bug: Caret now flashes behind blank behind "If", further 
         investigation of text in composer window shows that leading
         blanks have been added to all lines except first one.
12. Save as "Draft0002" 

Additional information:
a) Toggling between "Draft0002" ↔ "Draft0001" in Message pane shows
   difference in an impressive way
b) NOT reproducible  REPRODUCIBLE with  en-US SeaMonkey 2.40 final 
   Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) from official download
   page,  Gecko/20100101  Firefox/ 43.0  Build 20160120202951, 
   (Default Classic Theme) on German WIN7 64bit
c) When you open draft0.eml and draft1.eml in different Browser TABs
   you also see the difference like in (a)
(Reporter)

Comment 1

2 years ago
d) I did not find an obvious DUP with <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1276414&sharer_id=41036>
e) Same test results with IMAP or POP3 account
f) Not reproducible with HTML Web Page Composer
g) Also REPRODUCIBLE with English SeaMonkey 2.46a1 (X11; Linux x86_64; rv:49.0)
   Gecko/20100101 Firefox/49.0 Build   20160527003002 (Default Classic Theme) on
   VirtualBox Ubuntu 12.04 LTS
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

2 years ago
h) Already REPRODUCIBLE with unofficial 
   (from <http://seamonkey.callek.net/contrib/>)  English  SeaMonkey 2.43a1  
   Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0)  Gecko/20100101 Firefox/46.0 
   Build 20160116041507  (Default Classic Theme) on German WIN7 64bit
i) Was still ok  with  SeaMonkey 2.42a1 Mozilla/5.0 (Windows NT 6.1; WOW64;
   rv:45.0 from public download area)  Gecko/20100101  Firefox/ 45.0  
   Build 20151111021032, (Classic Theme) on German WIN7 64bit
k) No Problem for HTML email composer
Keywords: regression
OS: Windows 7 → All
Version: SeaMonkey 2.45 Branch → SeaMonkey 2.43 Branch

Comment 3

2 years ago
Do you see the same with mailnews.send_plaintext_flowed set to false?
And/or mailnews.display.disable_format_flowed_support set to true?

Leading spaces are inserted into lines which start with a leading space for format=flowed.
That's somehow a requirement of the standard (don't recall right now why).

Likely a MailNews Core or even a Serializer bug.
(Reporter)

Comment 4

2 years ago
NEW due to <https://blog.seamonkey-project.org/2015/11/25/my-unconfirmed-bug-reports/>
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.