Closed Bug 1276607 Opened 5 years ago Closed 5 years ago

The pointer from the text box is missing after disabling RDM

Categories

(DevTools :: Responsive Design Mode, defect, P1)

49 Branch
defect

Tracking

(firefox46 unaffected, firefox47 unaffected, firefox48 unaffected, firefox49 disabled, firefox50 disabled, firefox51 verified)

VERIFIED FIXED
Firefox 51
Iteration:
51.1 - Aug 15
Tracking Status
firefox46 --- unaffected
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- disabled
firefox50 --- disabled
firefox51 --- verified

People

(Reporter: mboldan, Assigned: jryans)

References

Details

(Keywords: regression, Whiteboard: [multiviewport] [reserve-rdm])

Attachments

(2 files)

Attached image missing pointer.gif
[Note]:
- Logged based on Bug 1240913 Comment 56

[Affected versions]:
- Firefox 49.0a1 (2016-05-29)

[Affected platforms]:
- Windows 10 x64, Ubunut 16.04 x64 and Mac OS X 10.10.5

[Steps to reproduce]:
1. Launch Firefox.
2. From about:config, enable the devtools.responsive.html.enabled pref.
3. Go to https://www.google.com.
4. Enable RDM.
5. Disable RDM and observe the pointer from the text box.

[Expected result]:
- The pointer is correctly displayed.

[Actual result]:
- After disabling RDM, the pointer is hidden (see the attached video).

[Regression range]:
- I think that this issue is caused by Bug 1240913. I'll investigate asap.
QA Whiteboard: [qe-rdm]
Flags: qe-verify+
Whiteboard: [multiviewport] → [multiviewport] [triage]
Priority: -- → P3
Whiteboard: [multiviewport] [triage] → [multiviewport] [reserve-rdm]
I managed to find a regression range Last good (2016-05-19) - First bad (2016-05-20).
Here is the pushlog from mozregression: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c4449eab07d39e20ea315603f1b1863eeed7dcfe&tochange=c67dc1f9fab86d4f2cf3224307809c44fe3ce820

Let me know if I can help any further with the investigation.
Is this feature enabled on release? Or is this something still in the works for the future and preffed off past aurora?
Flags: needinfo?(mmucci)
The feature is not enabled anywhere by default yet.
Flags: needinfo?(mmucci)
Thanks, that's what I thought. Marking this issue fix-optional for 49/50 (we don't really need to track it yet, but it's showing up on platform regression triage)
Priority: P3 → P2
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Iteration: --- → 51.1 - Aug 15
Priority: P2 → P1
Comment on attachment 8780324 [details]
Bug 1276607 - Activate content frame when stopping RDM to restore focus.

https://reviewboard.mozilla.org/r/71046/#review68656

Looks good to me!
Failures are related to intermittent bugs only, and that fix worked well when I tested it locally.
Attachment #8780324 - Flags: review?(bchabod) → review+
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e225f606ad70
Activate content frame when stopping RDM to restore focus. r=bigben
https://hg.mozilla.org/mozilla-central/rev/e225f606ad70
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
The issue is no longer reproducible on Firefox 51.0a1 (2016-08-16), under Windows 10x64, Mac OS X 10.11.1 and under Ubuntu 14.04 x64.
I am marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Hi Ryan, should we consider uplifting this to Beta50? It's tagged as a P1.
Flags: needinfo?(jryans)
(In reply to Ritu Kothari (:ritu) from comment #11)
> Hi Ryan, should we consider uplifting this to Beta50? It's tagged as a P1.

No, the feature is disabled by default.  I've updated the tracking flags.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.