Closed Bug 1276923 Opened 4 years ago Closed 4 years ago

White artifacts and flickering when scrolling on Vimeo videos

Categories

(Core :: Panning and Zooming, defect)

49 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla49
Tracking Status
e10s ? ---
firefox46 --- unaffected
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- verified

People

(Reporter: adalucinet, Assigned: jrmuizel)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached video Screencast
[Affected versions]:
- latest Nightly 49.0a1

[Affected platforms]:
- Windows 10 x64	
- Ubuntu 16.04 LTS x64	

[Steps to reproduce]:
1. Launch Firefox
2. Go to www.vimeo.com
3. Play a video 
- https://vimeo.com/167414855
- https://vimeo.com/40805886
4. Scroll down/up

[Expected result]:
- Video is properly displayed.

[Actual result]:
- White artifacts/flicker present.

[Regression range]:
- Last good revision: 132e391ed5e588241227dfb48083dcd57ac3142f
- First bad revision: 9542a06550b6c6e8ca512e705d9e3732036928a5
- Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=132e391ed5e588241227dfb48083dcd57ac3142f&tochange=9542a06550b6c6e8ca512e705d9e3732036928a5

[Additional notes]:
- Screencast attached.
- Not reproducible with layers.async-pan-zoom.enabled → false nor with e10s disabled,
- Unable to reproduce under Mac OS X 10.10.5
Assignee: nobody → jmuizelaar
tracking-e10s: --- → ?
Depends on: 1277306
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/724b9cdd239f
Actually disable ssse3 scaler until it's fixed. r=mstange
https://hg.mozilla.org/mozilla-central/rev/622c7afef4ae
https://hg.mozilla.org/mozilla-central/rev/724b9cdd239f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Attached patch Properly transform the clip (obsolete) — Splinter Review
Attachment #8759751 - Flags: review?(mstange)
This actually works
Attachment #8759751 - Attachment is obsolete: true
Attachment #8759751 - Flags: review?(mstange)
Attachment #8759766 - Flags: review?(mstange)
Comment on attachment 8759766 [details] [diff] [review]
More properly transform the clip

Review of attachment 8759766 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, this makes a lot of sense. We push the clip on the buffer while it has the original transform, and then we overwrite the transform with something else. But the fast path operates in device space and ignores the existing clip on the buffer, so we need to know the original clip at the original transform.

Maybe call transformedClipRect bufferDeviceClip? Up to you.
Attachment #8759766 - Flags: review?(mstange) → review+
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/49762b7df747
BasicCompositor: Properly transform the clip. r=mstange
Flags: qe-verify+
This issue is verified fixed on 49.0b7 (2016-08-25), using Windows 10 x64 and Ubuntu 16.04 LTS x64. I will mark this bug accordingly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.