Closed Bug 1277442 Opened 3 years ago Closed 3 years ago

Install fsmonitor or watchman on Linux in mach mercurial-setup

Categories

(Developer Services :: Mercurial: configwizard, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1277406

People

(Reporter: TYLin, Assigned: boris)

References

Details

Quoting "Platforms Supported" in [1] as follows.

     Linux: Stable. Watchman and fsmonitor are both known to work reliably, even under severe loads.

However, we only install it on Mac OS [2]. I guess we could install fsmonitor or even watchman on Linux as well.

[1] https://www.mercurial-scm.org/wiki/FsMonitorExtension
[2] https://dxr.mozilla.org/mozilla-central/rev/4d63dde701b47b8661ab7990f197b6b60e543839/tools/mercurial/hgsetup/wizard.py#361
The documentation for sys.platform is here https://docs.python.org/2/library/sys.html#sys.platform
Assignee: nobody → boris.chiou
Depends on: 1277134
I'm rewriting `mach mercurial-setup` in bug 1277406. I believe I addressed this there by removing the OS X check.

FTR, the OS X check is because we can't reliably compile Python C extensions on Linux. However, since fsmonitor is part of the Mercurial distribution, if you are running Mercurial 3.8, the fsmonitor C extensions should be part of the distribution. So it should be safe to load on Linux.
I should mention I did all that work today. It's something I've put off for way too long. As part of working on my Mercurial presentation for London, I realized I really needed to get that work done. I would have told you last night before you worked on the other fsmonitor bug, but you submitted a patch before I could warn you. Hopefully I reached you in time with these comments :)

If you want to build on top of my work in bug 1277406, please do. We finally have test coverage of the setup wizard after that series. So I feel much better about taking patches provided there is test coverage.
Component: mach → Mercurial: configwizard
Product: Core → Developer Services
See Also: → 1293688
This was addressed as part of bug 1277406.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277406
You need to log in before you can comment on or make changes to this bug.