should not try to set as default mail client if already default

VERIFIED DUPLICATE of bug 123596

Status

VERIFIED DUPLICATE of bug 123596
17 years ago
10 years ago

People

(Reporter: michael.wardle, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have enabled Mozilla MailNews as the default mail client (I thought this was
set in Edit->Preferences->Advanced->System, but I can't find it there), and
every time I run Mozilla as an unprivileged user, I get an annoying dialog box
(see bug 127762).

It seems silly that Mozilla is even trying to set itself as the default mail
client, as according to the registry it already is (confirmed by opening Outlook
Express, going to Options->Programs, and Mail Client was listed as Mozilla 0.9.8
or similar).

If the mail client is already the default mail client (default mailto: handler,
I guess that means), then it shouldn't try to set itself as default again (doing
so causes the aforesaid annoying and unnecessary error dialog box).
(Reporter)

Comment 1

17 years ago
build: Mozilla 20020204 (0.9.8) on Win2000

I've just noticed that despite being the "default" mail client, opening a
mailto: link in Internet Explorer invokes Outlook Express rather than Mozilla
MailNews.  Does this mean that Mozilla is not the default, after all?
(Reporter)

Comment 2

17 years ago
Sounds like the default mail client handling has been changed for 0.9.9 (bug
123596), meaning this bug *may* be invalid.  I'll download 0.9.9 when it comes
out and have a look.

*** This bug has been marked as a duplicate of 123596 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Mail Window Front End → Simple MAPI
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.