[e10s] Ooyala embedded flash video flashes black when scrolling

RESOLVED DUPLICATE of bug 1252874

Status

()

RESOLVED DUPLICATE of bug 1252874
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8759335 [details]
(initial broken testcase; disregard)

STR:
1. Load attached testcase.
(Or, load this URL:
  http://www.vox.com/2016/6/2/11841074/trump-cnn-chyron
...and scroll down to the "Trump's Twitter by the numbers" video below the article.)

2. Scroll up and down with mousewheel or arrow keys.

ACTUAL RESULTS:
The embedded flash video ("Donald Trump's Twitter by the numbers") turns entirely black while the scroll operation is happening.

EXPECTED RESULTS:
Embedded flash video shouldn't change appearance when scrolling.
(Reporter)

Comment 1

3 years ago
Created attachment 8759337 [details]
testcase 1 (using remote ooyala embed script)

[Updating testcase to refer to script using HTTPS instead of HTTP, so it hopefully won't get blocked...]
Attachment #8759335 - Attachment is obsolete: true
(Reporter)

Comment 2

3 years ago
Created attachment 8759341 [details]
screencast of bug

Here's a screencast of the bug. As shown later in the screencast, the bug doesn't reproduce if I click and drag the scrollbar -- it only reproduces on scrollwheel & keyboard uparrow/downarrow presses.
(Reporter)

Comment 3

3 years ago
Created attachment 8759344 [details]
testcase 2 (with border/background added on wrapper div)
(Reporter)

Updated

3 years ago
Attachment #8759335 - Attachment description: testcase 1 (using remote ooyala embed script) → (initial broken testcase; disregard)
(Reporter)

Comment 4

3 years ago
If I disable smooth-scrolling, our behavior is even more bizarre -- the video simply doesn't move when I scroll (though testcase 2's border/background do move), until a paint is forced due to e.g. a click or a focus-change.
(Reporter)

Comment 5

3 years ago
Created attachment 8759349 [details]
screencast of testcase 2, with smooth-scroll disabled
(Reporter)

Comment 6

3 years ago
Version info:
 Nightly 49.0a1 (2016-06-02)
 Flash 11.2 r202
 Ubuntu Linux 16.04 (64-bit)

Updated

3 years ago
Flags: needinfo?(jmathies)
(Reporter)

Comment 7

3 years ago
Happily, I can't reproduce any of the issues here in Nightly on Windows 10 (with Flash 21.0.0.242).

So: might just be a bug in the legacy Flash release that Linux users are stuck with... (Or, maybe a legit Gecko plugin-interaction bug that's only exposed with that particular version.)
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Sorry, we didn't block on the linux scroll capture bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jmathies)
Resolution: --- → DUPLICATE
Duplicate of bug: 1252874
You need to log in before you can comment on or make changes to this bug.