Closed Bug 1277719 Opened 4 years ago Closed 4 years ago

Maximum image zoom level seems more restricted than before

Categories

(Firefox for Android :: Toolbar, defect)

48 Branch
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 49
Tracking Status
firefox46 --- unaffected
firefox47 --- unaffected
firefox48 --- verified
firefox49 --- verified

People

(Reporter: JanH, Assigned: kats)

References

()

Details

(Keywords: regression)

Attachments

(3 files)

Viewing an image, I can no longer zoom in as much as I used to. This currently affects Nightly and Aurora, so can I blame APZ?
Yeah, probably APZ-related. There's a MAX_ZOOM const in AsyncPanZoomController.cpp which is probably what's clamping it here. We could try bumping that up and see if it helps.
Keywords: regression
Yeah, cranking that MAX_ZOOM up to 16.0 allows zooming in to the same level as the Java PZC. I think the kViewportMaxScale at [1] becomes the next limiting factor, which is fine. So if we put the MAX_ZOOM at 10.0 it should fix this bug without introducing unnecessary zoom power. And since Fennec is currently the only platform that supports pinch-zooming in APZ we might as well just make the change.

[1] http://mxr.mozilla.org/mozilla-central/source/dom/base/nsViewportInfo.h?rev=37d64688bf9d#16
Assignee: nobody → bugmail.mozilla
Actually we do need it to go all the way to 16.0, the kViewportMaxScale is in different units.
Comment on attachment 8759788 [details]
Bug 1277719 - Remove unnecessary duplicated zoom bounds from APZC and make nsViewportInfo have the source of truth for those values.

https://reviewboard.mozilla.org/r/57666/#review54504
Attachment #8759788 - Flags: review?(rbarker) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e84b5b95e3a
Remove unnecessary duplicated zoom bounds from APZC and make nsViewportInfo have the source of truth for those values. r=rbarker
https://hg.mozilla.org/mozilla-central/rev/6e84b5b95e3a
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Verified as fixed in build 49.0a2 (2016-06-15);
Device: 
- Asus ZenPad 8 (Android 5.0.2);
- Nexus 5 (Android 6.0.1).
Comment on attachment 8759788 [details]
Bug 1277719 - Remove unnecessary duplicated zoom bounds from APZC and make nsViewportInfo have the source of truth for those values.

Approval Request Comment
[Feature/regressing bug #]: APZ
[User impact if declined]: User is unable to zoom in on imageas as much as they could before
[Describe test coverage new/current, TreeHerder]: verified manually
[Risks and why]: fairly low risk, small change
[String/UUID change made/needed]: none
Attachment #8759788 - Flags: approval-mozilla-beta?
Comment on attachment 8759788 [details]
Bug 1277719 - Remove unnecessary duplicated zoom bounds from APZC and make nsViewportInfo have the source of truth for those values.

This patch fixes the regression. Take it in 48 beta 3.
Attachment #8759788 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed on Firefox 48 Beta 3
Status: RESOLVED → VERIFIED
Depends on: 1306371
You need to log in before you can comment on or make changes to this bug.