Black content, with error messages in Failure Log: CP+[GFX1-]: Detected rendering device reset on refresh

RESOLVED DUPLICATE of bug 1275798

Status

()

Core
Graphics
--
major
RESOLVED DUPLICATE of bug 1275798
a year ago
a year ago

People

(Reporter: jgilbert, Unassigned)

Tracking

49 Branch
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(e10s?, firefox49 affected)

Details

(Whiteboard: gfx-noted)

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8759503 [details]
about:support "Graphics"

GPU: AMD Radeon (TM) R9 390 Series

In case it becomes relevant, this is on a system with three monitors. (two 60Hz, one 90Hz with and without FreeSync)

Nothing seems to be in the failure log when it's working properly. However, once the content starts flashing, then staying black. Occasionally a pop-over image will show through when triggered by the mouse. (hover-over => pop-over zoomed image, as on Amazon product images)

This makes Firefox unusable on some sites, since it triggers relatively quickly, though non-deterministicly, on at least Amazon.
(Reporter)

Comment 1

a year ago
Created attachment 8759504 [details]
another about:support, starting with a CreateTexture2D failure
Flags: needinfo?(bas)
(In reply to Jeff Gilbert [:jgilbert] from comment #1)
> Created attachment 8759504 [details]
> another about:support, starting with a CreateTexture2D failure

Looks from that log we're having a device reset.. we must still not always be dealing with it properly when using e10s. Since you have a machine that can reproduce it we should probably figure out why we're not properly recreating everything on that machine when the device resets.
Flags: needinfo?(bas)
(Reporter)

Comment 3

a year ago
(In reply to Bas Schouten (:bas.schouten) from comment #2)
> (In reply to Jeff Gilbert [:jgilbert] from comment #1)
> > Created attachment 8759504 [details]
> > another about:support, starting with a CreateTexture2D failure
> 
> Looks from that log we're having a device reset.. we must still not always
> be dealing with it properly when using e10s. Since you have a machine that
> can reproduce it we should probably figure out why we're not properly
> recreating everything on that machine when the device resets.

I've built gecko on that machine, so I'll dive in a bit tomorrow.
(Reporter)

Updated

a year ago
Assignee: nobody → jgilbert

Updated

a year ago
tracking-e10s: --- → ?
"spam" in the title suggests these messages aren't useful :)

This is likely a duplicate of bug 1275798
Status: NEW → RESOLVED
Last Resolved: a year ago
OS: Unspecified → Windows
Resolution: --- → DUPLICATE
Summary: Black content, with spam in Failure Log: CP+[GFX1-]: Detected rendering device reset on refresh → Black content, with error messages in Failure Log: CP+[GFX1-]: Detected rendering device reset on refresh
Duplicate of bug: 1275798
(Reporter)

Updated

a year ago
Assignee: jgilbert → nobody
You need to log in before you can comment on or make changes to this bug.