Not able to see the slides properly in webkithacks with layout.css.prefixes.webkit=false

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: amogh.kudari5, Unassigned)

Tracking

46 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

509.56 KB, application/x-rar
Details
(Reporter)

Description

2 years ago
Created attachment 8759522 [details]
slide_png.rar

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

Open Firefox browser private mode version 46
Went to http://webkithacks.github.io/webkit_presentations/architecture/ link
Checked it in safe mode too it's the same behaviour.


Actual results:

All slide contents are overlapped with one another.
Cannot see the contents properly



Expected results:

Each slide content should have been rendered separately.
All slides shows the same content
http://webkithacks.github.io/webkit_presentations/architecture/#slide-4
and http://webkithacks.github.io/webkit_presentations/architecture/ link show the same content.

Just check if it's related to [Bug 1269321] 3D Rendering issue in special condition
(Reporter)

Comment 1

2 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Severity: normal → major
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Comment 2

2 years ago
Enabling css webkit prefix(layout.css.prefixes.webkit = true) seems to fix the problem.

So, I think this is the SITE PROBLEM.

Updated

2 years ago
Component: Untriaged → Layout
Product: Firefox → Core

Updated

2 years ago
Summary: Not able to see the slides properly in webkithacks → Not able to see the slides properly in webkithacks with layout.css.prefixes.webkit=false
(Reporter)

Comment 3

2 years ago
Hi,

 Even I am able to see the slides properly on setting layout.css.prefixes.webkit=true. 
I am newbie so wanted some info...
Is it a site problem or firefox has to be released with with above property set to true.

And It works directly on chrome. Is it because property is set to true by default in chrome(as it's based on webkit)? Will setting above property to false on chrome have similar issue as firefox..?

Updated

2 years ago
Flags: needinfo?(dholbert)
(In reply to amogh.kudari5 from comment #3)
>  Even I am able to see the slides properly on setting
> layout.css.prefixes.webkit=true. 

That will be the default configuration in Firefox 49. Before that, that about:config pref is disabled by default (because that's when we're pretty sure it's complete enough to ship; and when it's incomplete, some sites break as a result).

> I am newbie so wanted some info...
> Is it a site problem or firefox has to be released with with above property
> set to true.

It's a site problem.

It indicates that the site is using some Chrome/Safari-specific "aliases" for CSS properties, without using the modern standards-based versions of those properties that are supported in all browsers.

This is a problem that many sites have, though (in particular on mobile, due to Chrome/Safari dominance in the mobile browser market, which means web developers don't test other browsers as much). So, we're adding support for these Chrome/Safari-specific aliases to Firefox. That's the feature that's controlled by the about:config preference that you found.

Anyway -- I'll mark this as FIXED by bug 1213126, which is where we turned this pref on by default (in our development builds). And that should hit release in Firefox 49, via bug 1259345.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dholbert)
Resolution: --- → FIXED
Depends on: 1213126
I created a pull request to fix the site's CSS in the meantime, BTW:
 https://github.com/webkithacks/webkit_presentations/pull/1

If the site authors/maintainers accept that pull request, it'll fix the page immediately, I think.
(Reporter)

Comment 6

2 years ago
(In reply to Daniel from comment #4)
Thanks Daniel for information.
You need to log in before you can comment on or make changes to this bug.