Closed Bug 1277802 Opened 3 years ago Closed 2 months ago

some javascripts files are invisible both in inspector and firebug

Categories

(DevTools :: Debugger, defect, P3)

46 Branch
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: llyaudet, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(4 files, 1 obsolete file)

Attached file swagger-ui.js
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

I opened a file containing swagger-ui.


Actual results:

The included script swagger-ui.js was invisible both in inspector and Firebug.


Expected results:

The included script swagger-ui.js should have been visible
Attached file a html file referencing the js file (obsolete) —
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Hi,

I also tried to reproduce the bug in Chrome and IE.

The js file was visible in Chrome inspector.

With IE when I opened the inspector the first time, the window crashed.
I retried one more time with IE and the js file was visible in the inspector.

Best regards,
   Laurent Lyaudet
Attached file 1277802.html
Attachment #8759578 - Attachment is obsolete: true
Component: Untriaged → Developer Tools: Debugger
If you refresh the page when the Debugger is open, the JS sources appear. I think there is an issue about caching or delay, maybe due to the size of the JS lib linked.
Hi Loic,

I tried to refresh the page with the debugger open but the file swagger-ui.js still doesn't show.

Best regards,
  Laurent Lyaudet
Even with a forced refresh? (ctrl+f5)
Hi Loic,

Even with a forced refresh it doesn't appear in Debugger tab.
However it appears in network tab.

Best regards,
   Laurent Lyaudet
My first thought was that swagger.js does not define any global functions. In that case all scripts introduced by this source file can be garbage collected before the debugger is opened. The debugger relies on those scripts to find the list of sources, which would explain why it doesn't show up.

However, on closer examination, it looks like swagger.js defines plenty of global functions, so that explanation seems out. We should take a closer look at this when we have the time.
Priority: -- → P3
Product: Firefox → DevTools
Blocks: dbg-sources
Whiteboard: needs-review
Attached image image.png

I tested this and I can see the swager-ui.js file in the Sources panel (together with the generated index.js file)

I am closing this since the new debugger UI seems to be dealing with this module properly. Feel free to reopen if you still see the problem though.

Honza

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
Whiteboard: needs-review
You need to log in before you can comment on or make changes to this bug.