Crash in OOM | unknown | js::AutoEnterOOMUnsafeRegion::crash | JSCompartment::wrap

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: CristiComo, Unassigned)

Tracking

(Depends on: 1 bug, {crash})

Trunk
All
Windows
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 affected, firefox47 affected, firefox48 affected, firefox-esr45 affected)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-0761f546-8f2d-479c-bb65-6afdc2160603.
=============================================================
Ran into this crash on Windows 10 x32 while I was testing a close up in google maps and scrolling, using Fx 47.0RC build 2. 
I have encountered this issue once, I don't have proper steps to reproduce.
Updating the tracking flags based on the socorro reports.
Crash volume for signature 'OOM | unknown | js::AutoEnterOOMUnsafeRegion::crash | JSCompartment::wrap':
 - nightly (version 50): 0 crashes from 2016-06-06.
 - aurora  (version 49): 0 crashes from 2016-06-07.
 - beta    (version 48): 1524 crashes from 2016-06-06.
 - release (version 47): 3581 crashes from 2016-05-31.
 - esr     (version 45): 828 crashes from 2016-04-07.

Crash volume on the last weeks:
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       0       0       0       0       0       0       0
 - aurora        0       0       0       0       0       0       0
 - beta        271     241     248     196     165     172     146
 - release     421     443     403     469     522     561     521
 - esr          99      88      94      60      99     107      59

Affected platform: Windows
status-firefox-esr45: --- → affected
The only place I can see AutoEnterOOMUnsafeRegion used under putWrapper is when adding the entry to the generic store buffer.

This should be addressed by bug 1225577 because that will remove this and replace it with stable hashing which is fallible.
Depends on: 1225577
This should be fixed by the patch in bug 1293127 because it removed the only place we crash on OOM in putWrapper.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
See Also: → bug 1303575

Updated

a year ago
Depends on: 1293127
You need to log in before you can comment on or make changes to this bug.