Ask to Activate not working for Flash anymore

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
major
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Antti Tervasmäki, Unassigned)

Tracking

({regression})

49 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49- fix-optional)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160602030220

Steps to reproduce:

In news sites flash films and other likes, do not prompt to activate Flash


Actual results:

I am told, that contents needs flash, or new version of flash


Expected results:

I am asked to activate Flash.
(Reporter)

Comment 1

2 years ago
Got a confirmation on mozillazine forums, so it is not only me.
And the same sites prompt to activate flash using Firefox 46.
(Reporter)

Comment 2

2 years ago
Noticed that plugincheck does not see Flash if it is set to "Ask to Activate" but sees silverlight though it is set "Ask to Activate", both are seen as "Always activate"...

Comment 3

2 years ago
STR
1. Flash is set to "Ask to Activate"
2. Open http://www3.nhk.or.jp/nhkworld/en/live/ for example


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a0ecfb9c274386956d390493efe732d184a922dc&tochange=7383d49bc7c8e9b1683d4dbfbe9642e112b9f43c

Triggered by; 7383d49bc7c8	Brad Lassey — bug 1186948 - remove plugins that are click-to-play from navigator.plugins (restricted to Flash) r=jst
Blocks: 1186948
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Product: Firefox → Core

Comment 4

2 years ago
[Tracking Requested - why for this release]:

And the following cnn page[1] silently fails. 
Nothing is indication except "Your video will begin momentarily".
[1] http://edition.cnn.com/2014/11/23/showbiz/music/katy-perry-super-bowl/index.html?hpt=en_bn1
status-firefox49: --- → affected
tracking-firefox49: --- → ?
Keywords: regression

Comment 5

2 years ago
This is partly an intentional change. Many sites now provide fall back to correct content when Flash is not enabled. However, you should still see some notification which allows you to enable Flash via the location bar (a reload will be required).

On http://www3.nhk.or.jp/nhkworld/en/live/ there is no notification, even in the location bar, so that's a straight-up bug.
status-firefox49: affected → ---
tracking-firefox49: ? → ---

Updated

2 years ago
status-firefox48: --- → unaffected
status-firefox49: --- → affected
tracking-firefox49: --- → ?
Severity: normal → major
Flags: needinfo?(blassey.bugs)
OS: Unspecified → All
Hardware: Unspecified → All
(Reporter)

Comment 6

2 years ago
OK, seen that notification on ONE site...  But most seem to claim I need to install Flash...
As Benjamin said, this is at least partially intended. The intention is to get the flash fall back content from sites while still showing our UX for prompt to activate. In some cases that fallback content will be a message asking you to install flash. We should investigate examples of sites that don't trigger our activation prompt.

Side note, I think that "install flash" content is pretty standard. Perhaps we should detect that and replace it with the in-content activation.
Flags: needinfo?(blassey.bugs)

Comment 8

2 years ago
Resolved by backout of the original bug. We'll reland when the behavior is fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Tracking in the original bug.
status-firefox49: affected → fix-optional
tracking-firefox49: ? → -
You need to log in before you can comment on or make changes to this bug.