Crash in OOM | large | mozalloc_abort | mozalloc_handle_oom | moz_xrealloc | sqlite3AffinityType

RESOLVED WORKSFORME

Status

()

Core
General
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: philipp, Unassigned)

Tracking

({crash, regression})

47 Branch
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(firefox47+ unaffected, firefox48 unaffected, firefox49 unaffected)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-c98edd80-3b20-44d7-ac03-a6fcf2160602.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	mozglue.dll 	mozalloc_abort(char const* const) 	memory/mozalloc/mozalloc_abort.cpp:33
1 	mozglue.dll 	mozalloc_handle_oom(unsigned int) 	memory/mozalloc/mozalloc_oom.cpp:46
2 	mozglue.dll 	moz_xrealloc 	memory/mozalloc/mozalloc.cpp:107
3 		@0xfffffffe 	
4 	nss3.dll 	sqlite3AffinityType 	db/sqlite3/src/sqlite3.c:95462
5 	xul.dll 	xul.dll@0x1e24f3b 	
6 	nss3.dll 	PR_Unlock 	nsprpub/pr/src/threads/combined/prulock.c:328
7 	xul.dll 	nsAppShell::ProcessNextNativeEvent(bool) 	widget/windows/nsAppShell.cpp:402
8 	winmm.dll 	timeGetTime 	
9 	xul.dll 	mozInlineSpellResume::Run() 	extensions/spellcheck/src/mozInlineSpellChecker.cpp:492
10 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:994

[Tracking Requested - why for this release]:
this signature has sprung up in 47 RC1 & RC2 builds (though it seems to have been present earlier on during the 44 release as well). currently it is on #22 with 0.4% of crashes on 47.0b99 and present on all versions of windows.

there were only a handful of changes between 47.0b9 and 47.0b99: https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=FIREFOX_47_0b9_RELEASE&tochange=FIREFOX_RELEASE_47_BASE - out of them bug 1272652 looks remotely related.

Comment 1

2 years ago
While this is a valid issue, I don't think this should block the Fx47 release as it's ranked at #22 so definitely not a top crasher so far. Depending on how things unfold on release channel, the severity of this crash could change.

Comment 2

2 years ago
Tracked for 47.
tracking-firefox47: ? → +

Comment 3

2 years ago
Mak, is there some way we can work around this OOM?
status-firefox47: affected → wontfix
status-firefox49: --- → affected
Flags: needinfo?(mak77)
honestly there isn't enough info to do anything here... We don't even know what is taking up all the memory.
bug 1272652 changed the order things happen, not the amount of work.
uptime 2472 seconds (41 minutes and 12 seconds) is unlikely to be a migration from another browser...
Flags: needinfo?(mak77)
So, considered he uptimes, I don't think this OOM has anything to do with migration.

At a maximum there may be a relation with the Sqlite.jsm change, but I could not really guess what the relation could be. Maybe something is doing a very large transaction and before we were giving up? but it would then happen more often...

There are also reports on Firefox 44.0.2 and then we didn't have any of these changes. Sounds like there is an oom activated by something that happened in these 2 releases (specific PGO combination? not sure)
Note, we could backout the Sqlite.jsm change to see if there's a relation. it is not strictly needed for the fix in bug 1272652, even if it could have helped similar cases. I have no idea if that would help, but it's a oneline change anyone can do, and I'd r=me that change since it's just an enhancement.
(Reporter)

Comment 8

2 years ago
i will keep an eye on the signature if it continues in this volume in 48 beta builds and will report back here in the bug. in that case we could try to revert the Sqlite.jsm change.
(Reporter)

Comment 9

2 years ago
so far it isn't showing up in RC3 crash data at all which is a good sign :-)
(Reporter)

Comment 10

2 years ago
seems to have been a one-off in those two rc builds...
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox47: wontfix → unaffected
status-firefox48: ? → unaffected
status-firefox49: affected → unaffected
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.