Issue with flexbox and -webkit prefixes in Firefox 48 developer edition

RESOLVED DUPLICATE of bug 1274096

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 1274096
2 years ago
2 years ago

People

(Reporter: jobs, Unassigned)

Tracking

48 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8759982 [details]
FF 48 flexbox issue

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/50.0.2661.102 Chrome/50.0.2661.102 Safari/537.36

Steps to reproduce:

Go to https://updown.io/ngg8 with FF 48.0a2 (2016-06-04)


Actual results:

All flexbox are broken because firefox *thinks* it understands the "display: -webkit-flex" property and uses it instead of the previous "display: flex" one. Whereas it actually doesn't understand it and effectively disabled flexbox. (see attached screenshot) if I just untick the "-webkit" version from the inspector, the flexbox are working fine. I understand that I can probably fix this by changing the order of the properties to have the standard one last, but this is still a bug as this behavior is totally unexpected and unwanted.


Expected results:

The browser should disregard the webkit prefixed properties and values unless it really does interpret them as expected. I guess this may be a side effect of adding all those "-webkit" properties in 48 (https://developer.mozilla.org/en-US/Firefox/Releases/48)
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Flags: needinfo?(dholbert)
Thanks for the bug report!

This site has precisely the issue described in bug 1274096 comment 0. Its CSS is mis-ordered, looking like this:
 display: flex;
 display: -webkit-box;
 display: -webkit-flex;

(See bug 1274096 comment 0 for why that's problematic.)

In any case --  in latest Nightly, this works for me (renders like Chrome, as far as I can tell). It does *not* work in DevEdition, though, because it looks like we only uplifted the first half of bug 1274096! Glad we caught that now. I'll get the second half uplifted ASAP.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1274096
(Reporter)

Comment 2

2 years ago
You're welcome, sorry for the duplicate I didn't manage find the existing ticket.

Yeah I know the order is not following best-practices, and I'll change that.
I just wanted to notify you of the regression because you probably want to support this order anyway, this is a bug to use the webkit properties without understanding them.

It does work fine in regular FF releases, yes, the regression is only in the dev edition.

Thanks for adding me to the CC of the other ticket and have a nice day.
This should now be fixed in the latest Developer Edition (with date stamp "2016-06-06" in the "About" dialog). It's fixed for me, at least.  Please let me know if you can still reproduce any related trouble there, though.

(And thanks again for filing this bug; it's good that we caught the missed patch-uplift on bug 1274096 sooner, rather than later.)
(Reporter)

Comment 4

2 years ago
Great, thanks!
You need to log in before you can comment on or make changes to this bug.