Closed Bug 127818 Opened 18 years ago Closed 5 years ago

Lack of documentation for moving bugs between BZ-Installations

Categories

(Bugzilla :: Documentation, defect, P3)

2.15
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: andreas.hoefler, Unassigned)

Details

Bugzilla has a feature to move bugs between different installations of Bugzilla
since it can be enabled on the parameters-page.
But there is nowhere any documentation on how to move the bugs or what
requirements on both BZ's have to be met to successfully move bugs.
Barnboy changed his email address and opened a new account instead of having the
address changed on his existing one.  Reassigning all docs bugs to his new account.
Assignee: barnboy → mbarnson
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.16
This would be a new section under "Administering Bugzilla". Myk/Dawn - b.m.o is
probably the only installation to use this feature. Could one of you write it up?

Gerv
This documentation "feature" isn't going to make 2.16 unless someone writes it,
because I can't, really.

Gerv
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Unfortunately, I have no experience with this procedure myself.  Has anyone
written a little blurb on it that I could include in the Guide?  Otherwise, I'll
simply have to include a note that indicates if you wish to use the movebugs
feature, you'll need to read the source code to understand how it works.
Status: NEW → ASSIGNED
Resolving fixed, included blurb about movebugs, basically saying it's an
undocumented feature and you'll need to consult the code.  Sorry to be so terse
on it, but it's not something anybody's using often enough, and has enough
interest in documenting its use, to have good working documentation on it.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
That's a non-answer.

What we need to do is get someone who has used it to tell us what they've done...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
hint hint, endico....
I'm someone who has tried it, my results:
- messed up a vanillia (target) BZ twice
- messed up the bugs in the originating BZ
- wasted lot of time trying to understand obscure scripts
- found bug when transferring bugs which contain umlauts(ä,ö,ü,ß) in any comment
(which happens quite every bug on a german-speaking company)
- lost some attachments

Finally we ended up transferring the bugs one by one by hand...

This is the cause why I originally started this bug because I think with a
proper documentation it would have been possible to avoid many of the problems
we've encountered.
Status: REOPENED → ASSIGNED
Matthew is still going to be around to help out, but Jake is taking over the
day-to-day front-line triage type stuff for Documentation
Assignee: matthew → jake
Status: ASSIGNED → NEW
Jake is leaving for a while (Reserve unit got called up), and we don't have a
new docs owner yet.  Anyone interested in helping out, please add
documentation@bugzilla.org to your watch list in your email preferences in Bugzilla.
Assignee: jake → documentation
*** Bug 239193 has been marked as a duplicate of this bug. ***
QA Contact: mattyt-bugzilla → default-qa
I can take care of this, if someone takes care of read my final doc and check for basic syntax mistakes like mixing have/has be/been :-). English is not my native language, however I work in english doing web programming since many years ago.

Also I've no experience at all with bugzilla running on windows, so do not now anything abuot windows support for importxml.pl and whatever I write will be based on my experience with importxml in different linux distros.

It would look somethign like this:

1. How bug move works.
2. Source installation setup.
3. Destination installation setup.
4. Testing the moves
5. Workarounds for special chars 
6. Testing the move.
7. Troubleshooting.

I think the most sensitive part is point 3 which includes setting up your mail server, as with each mail server things work differently.
My whole experience is using it with Sendmail, I could try to set it up with other mail servers but it would be much useful if someone who have experience setting it up with other servers could contribute to that item. I think if we can cover besides Sendmail, postfix & exim it would be excellent.

Regarding the point five, I've reduced the required hacks to support move bugs with special charsets to just a couple of lines and a perl module named Text::Iconv. Apply the same change after every major release and works like a charm. Oh, all this if both installations have utf8 disabled.

I've never submited that code because I believe bugzilla do not want to support iso-8859-1 and other special charsets in favour of move people to use utf8. If I'm wrong please tell me so and i'll take care of submit the code to support special charsets on bug moves.

Any comments?
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Bugzilla 2.20 is no longer supported. Retargetting to 2.22.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
Bugzilla 2.22 is no longer supported.
Target Milestone: Bugzilla 2.22 → ---
Bug moving is now an extension. Extensions can have docs. However, I'm not sure anyone knows how this works any more...

Gerv
The OldBugMove extension is no longer part of the core (bug 1102899). So WONTFIX.

Gerv
Status: NEW → RESOLVED
Closed: 17 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.