WebExtension is not installed without Gecko ID

RESOLVED DUPLICATE of bug 1269454

Status

RESOLVED DUPLICATE of bug 1269454
3 years ago
8 months ago

People

(Reporter: cbadescu, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox46 unaffected, firefox47 unaffected, firefox48 affected, firefox49 affected)

Details

(Reporter)

Description

3 years ago
[Affected versions]:
Firefox 49.0a1 (2016-06-05)
Firefox 48.0a2 (2016-06-05)

[Affected platforms]:
Windows 7 64-bit
Ubuntu 16.04 32-bit
Mac OS X 10.11 

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Create the xpinstall.signatures.dev-root pref in about:config and set it to true.
3.Install the following WebExtension: 
https://addons-dev.allizom.org/en-US/firefox/addon/i-m-a-gentleman/

[Expected results]:
- The WebExtension is successfully installed.

[Actual results]:
- The WebExtension could not be installed because it appears to be corrupted.
- The following logs are thrown in Browser Console: http://pastebin.com/eypmL9q6 

[Additional notes]:
- This WebExtension was submitted in AMO-dev.
- The same WebExtension is installed if the Gecko ID is specified in manifest.json, but based on https://github.com/mozilla/addons-server/issues/1890 the Gecko ID is not mandatory.
- According to Bug 1262005, FF 46 and FF 47 are not affected.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269454

Updated

8 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.