Last Comment Bug 127821 - Residual underline on a:hover with text-decoration:underline
: Residual underline on a:hover with text-decoration:underline
Status: RESOLVED WONTFIX
[CSS1-2.1][CSS1-5.4.3]
: css2, testcase
Product: Core Graveyard
Classification: Graveyard
Component: GFX (show other bugs)
: Trunk
: x86 All
: P3 normal with 1 vote (vote)
: Future
Assigned To: general
: Hixie (not reading bugmail)
:
Mentors:
http://www.webforma.it/supporto/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-26 02:18 PST by Davide G. Borin
Modified: 2014-09-24 16:37 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
residual hover underlines (10.16 KB, image/png)
2003-01-04 00:02 PST, Christian Campbell
no flags Details
Tescase (578 bytes, text/html)
2004-11-25 03:05 PST, Pavel Franc - Mozilla.cz
no flags Details

Description Davide G. Borin 2002-02-26 02:18:05 PST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

Moving the pointer from bottom to top of the link list, the third and the fourth
links ("Soluzione ai problemi di posta" and "Virtual Network Computing (VNC)")
show a double height underline when "hovered" and the lower(?) line doesn't
disappear when the pointer moves away.
The problem doesn't appear moving the pointer from top to bottom and this
movement clears the residual underlines too.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.webforma.it/supporto/
2.Move the pointer from bottom to top in the links list (from "Area riservata"
to "Istruzioni per la lettura dei log generati da Webalizer")


Actual Results:  The third and the fourth links ("Soluzione ai problemi di
posta" and "Virtual Network Computing (VNC)") show a double height underline
when "hovered" and the lower(?) line doesn't disappear when the pointer moves away.

Expected Results:  All links should appear the same when "hovered", without
residual underlines.

Both HTML and CSS are validated with W3C validators.
Comment 1 Waheed Islam 2002-02-26 05:43:52 PST
wfm - but i'm on win2k using 20020225.
Comment 2 Sébastien Desvignes 2002-02-26 05:53:32 PST
I see no problem with build 2002022503 on Win2000
Comment 3 Mathias Bogaert 2002-02-26 07:26:57 PST
Unable to reproduce. Build ID 2002022408 win2k
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2002-02-26 09:54:44 PST
I see this, linux build 2002-02-24-06.  Painting bug -- simply moving another
window on top of the mozilla one fixes things.
Comment 5 R.B. 2002-02-26 14:29:39 PST
WFM Linux (Debian potato), build 2002022221.
Comment 6 Christian Campbell 2003-01-04 00:02:20 PST
Created attachment 110641 [details]
residual hover underlines
Comment 7 Christian Campbell 2003-01-04 00:05:15 PST
The original URL works for me, but <http://www-test.cise.ufl.edu/> exhibits
similar behaviour to that originally described. Mousing up over links leaves
residual underlines that get erased when moused down over; mousing down in the
first place works fine.

Also, the underlining is too thin on the larger text. In attachment 110641 [details] the
mouse (invisible) is hovering over the lower left text, "Facilities and
Administration." The lower rule should be the same thickness of the upper rule
under that link's text.
Comment 8 Christian Campbell 2003-01-04 00:09:04 PST
Well, hell, I forgot to state my particulars: Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.3a) Gecko/20021212 on Windows XP.
Comment 9 Anne (:annevk) 2003-11-29 15:42:49 PST
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031128

Is this still a problem?
Comment 10 Davide G. Borin 2003-12-11 09:05:53 PST
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20031210

Still wrong.
Comment 11 Pavel Franc - Mozilla.cz 2004-11-25 03:05:58 PST
Created attachment 167008 [details]
Tescase

Tescase for residual underline. It shows the bug also on windows. Try to hover
the links from sides or from below.
Comment 12 Anders G. Jørgensen 2009-08-04 10:03:57 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090804 Minefield/3.6a1pre (.NET CLR 3.5.30729)

Can't reproduce using the testcase.
Comment 13 David Baron :dbaron: ⌚️UTC-10 2009-08-04 11:46:59 PDT
Probably fixed whenever we made text-decorations contribute to overflow areas.
Comment 14 Gordon P. Hemsley [:GPHemsley] 2014-09-24 16:37:44 PDT
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]

Note You need to log in before you can comment on or make changes to this bug.