Web driver crashes on Windows 10

RESOLVED DUPLICATE of bug 1278605

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1278605
2 years ago
2 years ago

People

(Reporter: Greg Whitworth, Unassigned)

Tracking

({crash})

49 Branch
x86_64
Windows 10
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.82 Safari/537.36 Edge/14.14359

Steps to reproduce:

Launching the build we received using WebDriver crashes consistently on my device.

I’m using wires.exe (I think v0.6.2) as the Puppet driver. It crashes consistently on startup before we navigate.


Actual results:

Crash: 

# Child-SP          RetAddr           Call Site
00 000000af`f1dfe8a0 00007ffb`56da7339 xul!mozilla::LoadInfo::GetUpgradeInsecureRequests+0xb95a1
01 000000af`f1dfe8d0 00007ffb`56965223 xul!imgLoader::SupportImageWithMimeType+0xd8a5d
02 000000af`f1dfe900 00007ffb`5642127c xul!NS_StringContainerFinish+0x12e1f3
03 000000af`f1dfeb50 00007ffb`564201ea xul!NS_NewNativeLocalFile+0x155d0
04 000000af`f1dfeb80 00007ffb`5641fa0e xul!NS_NewNativeLocalFile+0x1453e
05 000000af`f1dfebd0 00007ffb`56420b1d xul!NS_NewNativeLocalFile+0x13d62
06 000000af`f1dfec20 00007ffb`5644785d xul!NS_NewNativeLocalFile+0x14e71
07 000000af`f1dfecb0 00007ffb`5644686b xul!NS_StringSetIsVoid+0x915
08 000000af`f1dfece0 00007ffb`57e8f7ba xul!mozilla::services::_external_GetXULOverlayProviderService+0x2fb
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\Program Files\Nightly\nss3.dll - 
09 000000af`f1dfed10 00007ffb`5a016f4d xul!mozilla::LoadInfo::AddRef+0x473d06
0a 000000af`f1dfefd0 00007ffb`5a0064be nss3!SSL_SetURL+0x2fd
0b 000000af`f1dff000 00007ffb`5a0038de nss3!DTLS_GetHandshakeTimeout+0x4916
0c 000000af`f1dff030 00007ffb`5a01672f nss3!DTLS_GetHandshakeTimeout+0x1d36
0d 000000af`f1dff060 00007ffb`57eae471 nss3!SSL_AuthCertificateComplete+0x53
0e 000000af`f1dff090 00007ffb`57e85eec xul!mozilla::LoadInfo::AddRef+0x4929bd
0f 000000af`f1dff0c0 00007ffb`5642d25f xul!mozilla::LoadInfo::AddRef+0x46a438
10 000000af`f1dff0f0 00007ffb`5644b827 xul!XRE_AddStaticComponent+0xa23f
11 000000af`f1dff2d0 00007ffb`564bb7c5 xul!NS_StringSetIsVoid+0x48df
12 000000af`f1dff300 00007ffb`5642d25f xul!mozilla::LoadInfo::TriggeringPrincipal+0x37c95
13 000000af`f1dff650 00007ffb`5644b827 xul!XRE_AddStaticComponent+0xa23f
14 000000af`f1dff830 00007ffb`5675d373 xul!NS_StringSetIsVoid+0x48df
15 000000af`f1dff860 00007ffb`56742d0f xul!mozilla::LoadInfo::GetScriptableOriginAttributes+0x288807
16 000000af`f1dff8d0 00007ffb`56742aaa xul!mozilla::LoadInfo::GetScriptableOriginAttributes+0x26e1a3
17 000000af`f1dff900 00007ffb`5643123e xul!mozilla::LoadInfo::GetScriptableOriginAttributes+0x26df3e
18 000000af`f1dff950 00007ffb`5a0bfe02 xul!XRE_AddStaticComponent+0xe21e
19 000000af`f1dff9a0 00007ffb`5a0b2f0a nss3!PR_NativeCreateThread+0x2c6
1a 000000af`f1dff9d0 00007ffb`bca7c6c0 nss3!PR_MD_WAIT_CV+0x1f36
1b (Inline Function) --------`-------- ucrtbase!invoke_thread_procedure+0xd [d:\rs1\minkernel\crts\ucrt\src\appcrt\startup\thread.cpp @ 91]
1c 000000af`f1dffa00 00007ffb`beddfa74 ucrtbase!thread_start<unsigned int (__cdecl*)(void * __ptr64)>+0x40 [d:\rs1\minkernel\crts\ucrt\src\appcrt\startup\thread.cpp @ 115]
1d 000000af`f1dffa30 00007ffb`bf5bfbe1 KERNEL32!BaseThreadInitThunk+0x14 [d:\rs1\base\win32\client\thread.c @ 64]
1e 000000af`f1dffa60 00000000`00000000 ntdll!RtlUserThreadStart+0x21 [d:\rs1\minkernel\ntdll\rtlstrt.c @ 997]


Expected results:

Startup successfully as it does when launching as a regular end user.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
ni? :heycam who made the custom build for Greg.
Flags: needinfo?(cam)

Comment 2

2 years ago
Likely a dupe of bug 1278605. We'll cut a new build after that lands.
Flags: needinfo?(cam)

Updated

2 years ago
Keywords: crash
Greg, does this work now?
Flags: needinfo?(gwhit)
Closing this issue due to lack of response from the reporter. If this issue does persist, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
To close the loop on this: the crash was in fact a dupe of Bug 1278605. New builds were working, but with some additional bugs... those are being addressed in an email thread and in other bugs. 

Thanks for reporting Greg!
Flags: needinfo?(gwhit)
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 1278605
You need to log in before you can comment on or make changes to this bug.