Submitting a job does not get grouped correctly

RESOLVED DUPLICATE of bug 1215587

Status

Tree Management
Treeherder
RESOLVED DUPLICATE of bug 1215587
a year ago
a year ago

People

(Reporter: armenzg, Unassigned)

Tracking

Details

(Reporter)

Description

a year ago
I'm submitting a job via the treeherder client to a local instance of treeherder, however, the job always get grouped under the 'unknown' group.

I actually don't want a group for the job, however, I noticed that even if I set the group name to be 'no group' and the group symbol to be 'XXX' it makes no difference.

What am I missing?


[{u'coalesced': [],
  u'job': {u'artifacts': [],
           u'build_platform': {u'architecture': u'x86_64',
                               u'os_name': u'linux',
                               u'platform': u'linux64'},
           u'desc': u'',
           u'end_timestamp': 1465314885,
           u'group_name': u'no_group',
           u'group_symbol': u'XXX',
           u'job_guid': u'57a59acf-937d-4171-9dd9-99bda0226d1c',
           u'job_symbol': u'Sch',
           u'log_references': [],
           u'machine': u'armenzg-thinkpad',
           u'machine_platform': {u'architecture': u'x86_64',
                                 u'os_name': u'linux',
                                 u'platform': u'linux64'},
           u'name': u'Add new jobs scheduling',
           u'option_collection': {u'opt': True},
           u'product_name': u'no product',
           u'reason': u'',
           u'result': u'success',
           u'start_timestamp': 1465314885,
           u'state': u'completed',
           u'submit_timestamp': 1465314885,
           u'tier': u'2',
           u'who': u''},
  u'project': u'try',
  u'revision': u'66537e88c60f84f69cd9f8b779c82cd5ddeee8de'}]
  
  From Job lists api:
              1465314885,
            "buildbot",
            "armenzg-thinkpad",
            "unknown",
            "unknown",
            "opt",
            "",
            1,
            1,
            "success",
            46,
            "x86_64",
            3,
            "linux64",
            "57a59acf-937d-4171-9dd9-99bda0226d1c",
            "Add new jobs scheduling",
            "7f9e2ad4c621177afb379ff5d71d788c02271e15",
            "linux64",
            "completed",
            0,
            1465314885,
            "linux",
            "unknown",
            "102210fe594ee9b33d82058545b1ed14f4c8206e",
            1,
            "Sch",
            "unknown",
            "",
            2,
            null,
            "linux",
            1465314885,
            "x86_64",
            "2016-06-07T15:54:46",
            "7f9e2ad4c621177afb379ff5d71d788c02271e15",
            1
"unknown" is a poor choice of name on our part, but it actually means "no group" in the current model.

We should probably just use the empty string.
(Reporter)

Comment 2

a year ago
It seems that the first time you post a job and set a group for it that is what it will be until someone fixes it on the DB.

This is now fixed for me.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Updated

a year ago
Summary: Submitting a job does not get group correctly → Submitting a job does not get grouped correctly
The fix for the root cause (rather than the one-off DB fix each time) is bug 1215587, marking a dupe of that for helping to track the scale of the issue.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1215587
You need to log in before you can comment on or make changes to this bug.