Disable predictor prefetch on aurora 49

RESOLVED FIXED in Firefox 49

Status

()

Core
Networking
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: nwgh, Assigned: nwgh)

Tracking

49 Branch
mozilla49
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 disabled, firefox49 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1268208 +++

Some regressions from bug 1016628 have still not been fixed. Let's disable on aurora again.
Created attachment 8760860 [details] [diff] [review]
disable-prefetch.patch
Attachment #8760860 - Flags: review?(honzab.moz)
Attachment #8760860 - Flags: review?(honzab.moz) → review+
Comment on attachment 8760860 [details] [diff] [review]
disable-prefetch.patch

Approval Request Comment
[Feature/regressing bug #]: 1016628
[User impact if declined]: known regressions
[Describe test coverage new/current, TreeHerder]: on beta (previously aurora)
[Risks and why]: none
[String/UUID change made/needed]: none
Attachment #8760860 - Flags: approval-mozilla-aurora?
Is this enabled on beta 48 and aurora 49? I want to make sure we're disabling it in the correct versions since this request was just after the merge.
status-firefox48: --- → ?
status-firefox49: --- → ?
tracking-firefox49: --- → ?
Flags: needinfo?(hurley)
No, this is only enabled on aurora 49. It was disabled for 48 back when that was aurora (bug 1268208).

I plan on landing a patch to ifdef the pref on m-c so we don't have to keep doing this dance every merge until I get the issues fixed (though hopefully that will be by the time 50 becomes aurora).
status-firefox48: ? → disabled
status-firefox49: ? → affected
Flags: needinfo?(hurley)
Thanks, yes probably ifdef is the way to go here until you are sure.
tracking-firefox49: ? → ---
Comment on attachment 8760860 [details] [diff] [review]
disable-prefetch.patch

Feature not ready, preffing it off for aurora 49. Please uplift.
Attachment #8760860 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/dd0fbfbe790f
status-firefox49: affected → fixed
So closing as fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
as a note, it appears we have fixed the perf issues on trunk (v.50)
You need to log in before you can comment on or make changes to this bug.