Deceptive Search Box UI Design

RESOLVED FIXED

Status

Webtools
Air Mozilla
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: richard, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
The Search Box on AirMo often returns unexpected results for users who are not exceptionally perceptive.

The problem is that users are conditioned to think of hitting the return key and clicking on the Submit button being equivalent operations.  In the case of the search box that's not true.

When you type word into the AirMo Search box, it pre-loads a set of search terms containing that word.  The first item in that list is selected by default and that search term is used if you hit the the return key.


To get the more general search using only the word you typed, you need to click on the Search button instead of hitting the return key.... a more awkward process that requires taking a hand off the keyboard.

Since either hitting return or clicking on the Search button clears the search term text box, the results can be deceptive because the list of events returned by the less general search may not include the event the user was looking for with the more general search, and it's not clear why.

The first item in the selection drop-down should not be selected by default.
(Reporter)

Updated

2 years ago
Priority: -- → P1
(Reporter)

Comment 1

2 years ago
Correction:   I was wrong about the search term box being cleared.  It isn't.
(Assignee)

Comment 2

2 years ago
> The first item in the selection drop-down should not be selected by default.

Yeah. I think I agree.
Assignee: nobody → peterbe
(Assignee)

Comment 3

2 years ago
This has been fixed in autocompeter.js along with some other optimizations.
Now we're just waiting for jsdelivr to update. 
We can close bug when https://cdn.jsdelivr.net/autocompeter/1/autocompeter.min.js mentions version 1.2.2 on the first line.

The new behavior is that the autocomplete box that appears doesn't matter until you use the down arrow.
(Assignee)

Comment 4

2 years ago
Latest autocompeter on prod now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.